Find a way

 Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’ express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input

4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#

Sample Output

66
88
66
#include <iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
const int Max=210;

char mp[Max][Max];
int vis[Max][Max];

//标记某家KFC被访问的次数,一共BFS两次,所以我们要找,all[][]是2的KFC,
//要不然可能只是一个人能到,但是另一个人到不了,但是时间还短,我们要排除这种//情况
int all[Max][Max];
int time[Max][Max];
int y_st_x,y_st_y,m_st_x,m_st_y;
int next_move[4][2]={{0,1},{0,-1},{1,0},{-1,0}};
int n,m;
int KFC;

typedef struct node
{
    int x,y;
    int step;
}Node;

int check(int x,int y)
{
    if(vis[x][y]||x<1||y<1||x>n||y>m||mp[x][y]=='#')
        return 1;
    return 0;
}

void bfs(int x,int y)
{
    memset(vis,0,sizeof(vis));
    queue<Node> q;
    Node now,next;
    now.x=x,now.y=y,now.step=0;
    vis[x][y]=1;
    q.push(now);
    int cnt=0;
    while(q.size())
    {
        now=q.front();
        q.pop();
        if(mp[now.x][now.y]=='@')
        {
          all[now.x][now.y]++;
          time[now.x][now.y] += now.step;
          cnt++;
          if(cnt==KFC)
                break;
        }
        for(int i=0;i<4;i++)
        {
            next.x=now.x+next_move[i][0];
            next.y=now.y+next_move[i][1];
            if(check(next.x,next.y))
                continue;
            next.step=now.step+1;
            vis[next.x][next.y]=1;
            q.push(next);
        }
    }
}

int main()
{
    while(~scanf("%d %d ",&n,&m))
    {
        memset(mp,0,sizeof(mp));memset(time,0,sizeof(time));
        memset(all,0,sizeof(all));
        KFC=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            scanf(" %c",&mp[i][j]);
            if(mp[i][j]=='Y')
                y_st_x=i,y_st_y=j;
            else if(mp[i][j]=='M')
                m_st_x=i,m_st_y=j;
            else if(mp[i][j]=='@')
                KFC++;
        }
        bfs(y_st_x,y_st_y);//确定时间

        bfs(m_st_x,m_st_y);//都能访问到才可以
        int ans=0x3f3f3f3f;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
        {
            if(mp[i][j]=='@'&&all[i][j]==2)
            {
                if(time[i][j]<ans)
                    ans=time[i][j];
            }
        }
        printf("%d\n",ans*11);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值