B - Common Tangents FZU - 2213

Problem 2213 Common Tangents

Accept: 814    Submit: 2357
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input

310 10 5 20 20 510 10 10 20 20 1010 10 5 20 10 5

Sample Output

423


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

const int maxn=110;
int p[maxn];
int x1,y1,r1,x2,y2,r2;
/*
主要是判断两个圆形
相交,但是不包含的时候写的有点问题
dis<(r1+r2)&&dis>(r2-r1) 
*/
int check(){
	int dis2=(y2-y1)*(y2-y1)+(x2-x1)*(x2-x1);
	if(dis2>(r1+r2)*(r1+r2)) return 4;
	if(dis2==(r1+r2)*(r1+r2)) return 3;
	if(dis2==0&&r1==r2) return -1;//重叠 
	if(r1>r2) swap(r1,r2);
	if(dis2==(r2-r1)*(r2-r1)) return 1;//内切 
	
	if(dis2<(r2-r1)*(r2-r1)) return 0;//	
	if(dis2<(r1+r2)*(r1+r2)&&dis2>(r2-r1)*(r2-r1))return 2;
	return 2;
}

int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d %d %d %d %d %d",&x1,&y1,&r1,&x2,&y2,&r2);
		int ans=check();
		printf("%d\n",ans);	
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值