FZU - 2213 Common Tangents

Problem 2213 Common Tangents

Accept: 836    Submit: 2436
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Two different circles can have at most four common tangents.

The picture below is an illustration of two circles with four common tangents.

Now given the center and radius of two circles, your job is to find how many common tangents between them.

Input

The first line contains an integer T, meaning the number of the cases (1 <= T <= 50.).

For each test case, there is one line contains six integers x1 (−100 ≤ x1 ≤ 100), y1 (−100 ≤ y1 ≤ 100), r1 (0 < r1 ≤ 200), x2 (−100 ≤ x2 ≤ 100), y2 (−100 ≤ y2 ≤ 100), r2 (0 < r2 ≤ 200). Here (x1, y1) and (x2, y2) are the coordinates of the center of the first circle and second circle respectively, r1 is the radius of the first circle and r2 is the radius of the second circle.

Output

For each test case, output the corresponding answer in one line.

If there is infinite number of tangents between the two circles then output -1.

Sample Input

310 10 5 20 20 510 10 10 20 20 1010 10 5 20 10 5

Sample Output

423

今天组队积分赛的题,队友很给力,A了五道题

这一道题是给出两个圆的圆心和半径,让你判断出来这两个圆有多少条公共切线

第一种情况:


第二种情况:



第三种情况:


第四种情况:


第六种情况:


第七种情况:

所以,代码如下:


#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<iostream>
using namespace std;

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		double x1,x2,r1,y1,y2,r2;
		scanf("%lf %lf %lf %lf %lf %lf",&x1,&y1,&r1,&x2,&y2,&r2);
		double d=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
		if(x1==x2&&y1==y2)
		{
			if(r1==r2)	cout<<"-1"<<endl;
			else		cout<<"0"<<endl;
		}
		else if(d>r1+r2)		cout<<"4"<<endl;
		else if(d==r1+r2)	cout<<"3"<<endl;
		else if(d<r1+r2&&d>fabs(r1-r2))	cout<<"2"<<endl;
		else if(d==fabs(r1-r2))	cout<<"1"<<endl;
		else if(d<fabs(r1-r2))	cout<<"0"<<endl;
	}
	return 0;
}



如有错误,请您指出,谢谢



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值