Number String ZOJ - 3543

The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.

Input

Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.

Output

For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.

Sample Input

II
ID
DI
DD
?D
??

Sample Output

1
2
2
1
3
6

Hint

Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.

这道dp题最巧妙的地方 感觉就在 那句  如果当前的位置放  x, 那么前面所有大于等于x的数可以看做同时+1,这样就是一个新排列了。 如果能想到这个等价性质,下面就比较好想了。 真是奇妙。

 

#include<bits/stdc++.h>
using namespace std;

typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)

const int N=1010;
char str[N];

LL dp[N][N],sum[N];

const int mod=1e9+7;

int main()
{
    while(scanf("%s",str+1)==1) {
        int n=strlen(str+1);

		rep(i,0,n+2)rep(j,0,n+2)dp[i][j]=0;

        dp[0][1]=1;
        sum[1]=1;
        for(int i=1; i<=n; i++) {
            if(str[i]=='I'||str[i]=='?') {
                for(int j=2; j<=i+1; j++) {
					//LL res=0;
					//for(int k=1;k<j;k++)res+=dp[i-1][k];
					dp[i][j]=(dp[i][j]+sum[j-1])%mod;
                }
            }
            if(str[i]=='D'||str[i]=='?') {
				for(int j=1;j<=i;j++){
					//LL res=0;
					//for(int k=j;k<=i;k++)res+=dp[i-1][k];
					dp[i][j]=(dp[i][j]+sum[i]-sum[j-1]+mod)%mod;
				}
            }
            for(int j=1;j<=i+1;j++)sum[j]=(dp[i][j]+sum[j-1])%mod;
        }
        printf("%lld\n",sum[n+1]);
    }
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值