zoj 3543 Number String(DP)

Number String
Time Limit: 5 Seconds      Memory Limit: 65536 KB
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".


Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.


Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.


Input


Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.


Each test case occupies exactly one single line, without leading or trailing spaces.


Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.


Output


For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.


Sample Input


II
ID
DI
DD
?D
??
Sample Output


1
2
2
1
3
6
Hint


Permutation {1,2,3} has signature "II".
Permutations {1,3,2} and {2,3,1} have signature "ID".
Permutations {3,1,2} and {2,1,3} have signature "DI".
Permutation {3,2,1} has signature "DD".
"?D" can be either "ID" or "DD".
"??" gives all possible permutations of length 3.


题意:给出一串字符串,含有“I”、“D”、或“?”,设字符串长度为n-1,现在要构造出长度为n的由1~n的数字所组成的排列,并满足给出字符串的要求:“I”表示后一个数要比前一个数要大,“D”表示后一个数要比前一个数要小,“?”表示后一个数可以比前一个大或者小。求满足要求的排列数。

思路:设dp[i][j]表示长度为i,最后一个数为j时的排列个数。

          if ( s[i] == 'I' ) dp[i][j] = dp[i-1][1] + dp[i-1][2] + ... + dp[i-1][j-1];
          if ( s[i] == 'D' ) dp[i][j] = dp[i-1][j] + dp[i-1][j+1] +...+ dp[i-1][i-1];
          if ( s[i] == '?' ) dp[i][j] = dp[i-1][1] + dp[i-1][2] + ... + dp[i-1][i-1];

用sum[i][j]表示dp[i][1]+dp[i][2]+dp[i][3]+....dp[i][j]


AC代码:

#include <iostream>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;
const int mod=1000000007;
int sum[1005][1005],dp[1005][1005];

int main()
{
    //freopen("1.txt","r",stdin);
    char s[1005];
    while(scanf("%s",s+2)!=EOF)
    {
        int len=strlen(s+2)+1;
        memset(sum,0,sizeof(sum));
        sum[1][1]=dp[1][1]=1;
        for(int i=2;i<=len;i++)
        for(int j=1;j<=i;j++)
        {
            if(s[i]=='I')
            dp[i][j]=sum[i-1][j-1];
            else if(s[i]=='D')
            dp[i][j]=sum[i-1][i-1]-sum[i-1][j-1];
            else
            dp[i][j]=sum[i-1][i-1];
            sum[i][j]=(sum[i][j-1]%mod+dp[i][j]%mod)%mod;
        }
        printf("%d\n",(sum[len][len]+mod)%mod);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值