POJ 2348 Euclid's Game

Euclid's Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9481 Accepted: 3884

Description

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 
         25 7

         11 7

          4 7

          4 3

          1 3

          1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

Source

博弈+GCD变式

思路如下:

首先分类讨论。

设两数分别为n,m,

当max(n,m)/min(n,m)>=2的时候

此时该方一定属于必胜态(因为可以让对方强制进入也可以使自己进入下一阶段)

然后当max(n,m)/min(n,m)==1时,这时候就可以用GCD改版计数+判断。


代码如下:
#include <iostream>
#include <stdio.h>
using namespace std;
typedef long long ll;
ll gcd(ll a,ll b,ll ans){
    if(!b)
        return ans;
    if(max(a,b)/min(a,b)>=2)
        return ans^1;
    return gcd(b,a%b,ans^1);
}

int main(){
    ll n,m;
    while(~scanf("%I64d%I64d",&n,&m)&&n&&m){
        puts(gcd(max(n,m),min(n,m),1)==0?"Stan wins":"Ollie wins");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值