POJ-3714 Raid

Raid
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 14080 Accepted: 4037

Description

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

Sample Output

1.414
0.000


只有1000+ms的代码


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
using namespace std;

const int maxn = 1e5+10;
const double INF = 1e20;

int t,n;
int a[maxn*2];

struct point{
    double x;
    double y;
    bool flag;
    void transXY(double B){
        double tx=x,ty=y;
        x = tx*cos(B)+ty*sin(B);
        y = ty*cos(B)-tx*sin(B);
    }
}p[maxn*2];

bool cmpx(const point &a,const point &b){
    return a.x<b.x;
}

bool cmpy(const int &a,const int &b){
    return p[a].y<p[b].y;
}

double dis(int i,int j){
    if(p[i].flag==p[j].flag) return INF;
    return sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
}

double closest(int low,int high){
    double ans = INF;
    if(low==high)
        return ans;
    if(low+1==high)
        return dis(low,high);
    int mid=(low+high)>>1;
    ans=min(closest(low,mid),closest(mid,high));
    int cnt=0;
    for(int i=low;i<=high;i++){
        if(abs(p[i].x-p[mid].x)<=ans)
            a[cnt++]=i;
    }
    sort(a,a+cnt,cmpy);
    for(int i=0;i<cnt;i++){
        for(int j=i+1;j<cnt;j++){
            if((p[a[j]].y-p[a[i]].y)<ans)
                ans=min(dis(a[i],a[j]),ans);

        }
    }
    return ans;
}

int main(){
    scanf("%d",&t);
    while(t--){
        double B = 90.0*rand()/double(RAND_MAX);
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%lf%lf",&p[i].x,&p[i].y);
            p[i].flag = true;
            p[i].transXY(B);
        }
        for(int i=n;i<2*n;i++){
            scanf("%lf%lf",&p[i].x,&p[i].y);
            p[i].flag = false;
            p[i].transXY(B);
        }
        sort(p,p+2*n,cmpx);
        printf("%.3f\n",closest(0,2*n-1));
    }
    return 0;
}


当然这样也能过:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-8;
const int maxn = 1e5+10;
const double INF = 1e20;

int t,n;
int cnt;
double ans;
double mint;
int a[maxn*2];

struct point{
    double x;
    double y;
    bool flag;
    void transXY(double B){
        double tx=x,ty=y;
        x = tx*cos(B)+ty*sin(B);
        y = ty*cos(B)-tx*sin(B);
    }
}p[maxn*2];

bool cmpx(const point &a,const point &b){
    return a.x<b.x;
}

double dis(int i,int j){
    if(p[i].flag==p[j].flag) return INF;
    return sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
}

double work(){
    for(int i=0;i<2*n-5;i++){
        for(int j=1;j<=5;j++){
            mint=min(dis(i,i+j),mint);
        }
    }
    for(int i=2*n-1;i>=5;i--){
        for(int j=0;i<5;j++){
            mint = min(mint,dis(i,i-j));
        }
    }
    return mint;
}

void trans(){
    double B = 30;
    for(int i=0;i<2*n;i++){
        p[i].transXY(B);
    }
    sort(p,p+2*n,cmpx);
    double tmp=work();
    ans=min(ans,tmp);
}

int main(){
    scanf("%d",&t);
    while(t--){
        cnt=0;
        mint=ans=INF;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%lf%lf",&p[i].x,&p[i].y);
            p[i].flag = true;
        }
        for(int i=n;i<2*n;i++){
            scanf("%lf%lf",&p[i].x,&p[i].y);
            p[i].flag = false;
        }
        for(int i=0;i<3;i++)
        trans();
        printf("%.3f\n",ans);
    }
    return 0;
}

还可以卡数据减少所需时间.

方法还可以优化可惜水平有限,


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值