Triangle HDU - 5914 (斐波那契数列的应用1123)

Mr. Frog has n sticks, whose lengths are 1,2, 3 n respectively. Wallice is a bad man, so he does not want Mr. Frog to form a triangle with three of the sticks here. He decides to steal some sticks! Output the minimal number of sticks he should steal so that Mr. Frog cannot form a triangle with 
any three of the remaining sticks.
Input
The first line contains only one integer T ( T20 T≤20), which indicates the number of test cases. 

For each test case, there is only one line describing the given integer n ( 1n20 1≤n≤20).
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1), y is the minimal number of sticks Wallice should steal.
Sample Input
3
4
5
6
Sample Output
Case #1: 1
Case #2: 1
Case #3: 2

刚开始看有点蒙,后来猜了几组数据,看着眼熟,于是搞出来了;

上代码;

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int  T;
int n;
int vis[20];
int main()
{
   scanf("%d", &T);
   vis[1] = vis[0] = 1;
   for(int i=2; i<=20; i++)
   {
	  vis[i] = vis[i-1] + vis[i-2];//构建斐波那契
   }
   for(int w=1; w<=T; w++)
   {
	 scanf("%d", &n);
     printf("Case #%d: ",w);
     for(int i=1; i<=20; i++)
     {
			if(vis[i] > n){cout << n-i+1 << endl;break;}
	 }
     
	}
     
	return 0;
}




水波.



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值