POJ 1738

There is an old stone game.At the beginning of the game the player picks n(1<=n<=50000) piles of stones in a line. The goal is to merge the stones in one pile observing the following rules: 
At each step of the game,the player can merge two adjoining piles to a new pile.The score is the number of stones in the new pile. 
You are to write a program to determine the minimum of the total score. 
Input
The input contains several test cases. The first line of each test case contains an integer n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game. 
The last test case is followed by one zero. 
Output
For each test case output the answer on a single line.You may assume the answer will not exceed 1000000000.
Sample Input
1
100
3
3 4 3
4
1 1 1 1
0
Sample Output
0
17
8

GarsiaWachs算法是从第一个石堆开始找符合stone[k-1]<stone[k+1]的石堆k,然后合并k-1与k堆,再向前找j堆石子,满足stone[j]>stone[k]+stone[k-1],插入到石堆j的后面。然后重新寻找。


代码:


#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int a[50010];
int now,ans;
int n;
void sol(int x)
{
   int i,j,tmp;
   tmp = a[x-1] + a[x];
   ans += tmp;
   for(i=x; i<now-1; i++)
    a[i] = a[i+1];
   now--;
   for(j=x-1; j>0&&a[j-1]<tmp; j--)
    a[j] = a[j-1];
    a[j] = tmp;
   while(j>=2 && a[j] >= a[j-2])
   {
   	  int dis = now - j;
   	  sol(j-1);
   	  j = now - dis;
   }  
   return ;
}
int main()
{
	while(~scanf("%d", &n))
	{
	  if(n==0)break;
	  for(int i=0; i<n; i++)
	  {  
	  	scanf("%d", &a[i]);
	  }
	  now = 1;
	  ans = 0;
	  for(int i=1; i<n; i++)
	  {
	   	a[now++] = a[i];
	   	while(now >= 3 && a[now-3] <= a[now-1])
	  	{
	  	   sol(now-2);	
		}
	  }
      while(now > 1) sol(now-1); 
	  cout << ans << endl;	  
    }
  return 0;	
} 

水波.

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值