Alice and Bob HDU - 4268

Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover. 
Please pay attention that each card can be used only once and the cards cannot be rotated. 
Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's. 
Output
For each test case, output an answer using one line which contains just one number. 
Sample Input
2
2
1 2
3 4
2 3
4 5
3
2 3
5 7
6 8
4 1
2 5
3 4 
Sample Output
1
2

A有n张不同的卡片,B也有n张不同的卡片,其中每个卡片只能用一次(即A的一张卡片只能覆盖一张B的卡片),问你A最多可以覆盖B的多少张卡片.

思路:

          对两个集合按照x进行升序排序,然后对a集合中的每个物品,在x满足的情况下,将对应的b集合中的物品扔入multiset中,然后在multiset中寻找y值最大的合法值,若找到++ans并将该值erase;


这里有坑,可以选用upper_bound简化代码,在之前应搞清楚upper_bound 与 lower_bound 的区别,推荐一下我的一点博客可以自找一下,还有就是注意迭代器不要越界.

上代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
int T;
multiset<int> op; 
struct node{
	int x;
	int y;
};
node a[100001];
node b[100001];
bool cmp(node c,node d)
{
	return c.x < d.x;
}
int main()
{
	scanf("%d" ,&T);
	int n;
	while(T--)
	{
	  scanf("%d", &n);
	  for(int i=1; i<=n; i++)
	  {
	    scanf("%d %d",&a[i].x, &a[i].y);		
	  }
	  for(int i=1; i<=n; i++)
	  {
	    scanf("%d %d",&b[i].x,&b[i].y);		
	  }
	  sort(a+1,a+1+n,cmp);
	  sort(b+1,b+1+n,cmp);
	  op.clear();
	  int j = 1;
	  int sum = 0;
	  for(int i=1; i<=n; i++)
	  {
		 for( ; j<=n; j++)
		 {
			if(a[i].x >= b[j].x)
			{
			  op.insert(b[j].y);   	
			}
			else break;
		 }
		 if(op.empty())continue;
		 multiset<int>::iterator it = op.upper_bound(a[i].y);
		 if(it == op.begin()){continue;}
		 if(*--it <= a[i].y){sum++; op.erase(it);}
      }
	printf("%d\n",sum );	
	}
	return 0;
}
水波.

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值