HDU 4268

Alice and Bob

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4420    Accepted Submission(s): 1398


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases.
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
  
  
2 2 1 2 3 4 2 3 4 5 3 2 3 5 7 6 8 4 1 2 5 3 4
 

Sample Output
  
  
1 2
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   4276  4274  4272  4267  4273 

 



两个人,各有n张牌,每张牌长为h,宽为w。问一个人的牌最多能覆盖另一个人的牌几张?覆盖的条件是一张牌长和宽都大于那张牌

贪心

先将h w排序  然后对于每个h,将另一方小的全都加入,对于w,二分查找其最大的W。

用个multiset维护下就好了。



#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll mod=2147493647;
const int N=1e5+10;
struct node
{
    int h,w;
} a[N],b[N];
bool cmp(node aa,node bb)
{
    if(aa.h!=bb.h)
        return aa.h<bb.h;
    else
        return aa.w<bb.w;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1; i<=n; i++)
            scanf("%d%d",&a[i].h,&a[i].w);
        for(int i=1; i<=n; i++)
            scanf("%d%d",&b[i].h,&b[i].w);
        sort(a+1,a+1+n,cmp);
        sort(b+1,b+1+n,cmp);
        multiset<int>q;
        multiset<int>::iterator it;
        q.clear();
        int cnt=1;
        int ans=0;
        for(int i=1; i<=n; i++)
        {
            int x=a[i].h;
            while(b[cnt].h<=x &&cnt<=n)
            {
                q.insert(b[cnt].w);
                cnt++;
            }
            it=q.lower_bound(a[i].w);
            if(q.empty())
                continue;
            if(*it==a[i].w)
            {
                ans++;
                q.erase(it);
            }
            else
            {
                if(it==q.begin())
                    continue;
                q.erase(--it);
                ans++;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值