Little Tiger vs. Deep Monkey HDU - 4815 (dp)

A crowd of little animals is visiting a mysterious laboratory – The Deep Lab of SYSU. 

“Are you surprised by the STS (speech to speech) technology of Microsoft Research and the cat face recognition project of Google and academia? Are you curious about what technology is behind those fantastic demos?” asks the director of the Deep Lab. “Deep learning, deep learning!” Little Tiger raises his hand briskly. “Yes, clever boy, that’s deep learning (深度学习/深度神经网络)”, says the director. “However, they are only ‘a piece of cake’. I won’t tell you a top secret that our lab has invented a Deep Monkey (深猴) with more advanced technology. And that guy is as smart as human!” 

“Nani ?!” Little Tiger doubts about that as he is the smartest kid in his kindergarten; even so, he is not as smart as human, “how can a monkey be smarter than me? I will challenge him.” 

To verify their research achievement, the researchers of the Deep Lab are going to host an intelligence test for Little Tiger and Deep Monkey. 

The test is composed of N binary choice questions. And different questions may have different scores according to their difficulties. One can get the corresponding score for a question if he chooses the correct answer; otherwise, he gets nothing. The overall score is counted as the sum of scores one gets from each question. The one with a larger overall score wins; tie happens when they get the same score. 

Little Tiger assumes that Deep Monkey will choose the answer randomly as he doesn’t believe the monkey is smart. Now, Little Tiger is wondering “what score should I get at least so that I will not lose in the contest with probability of at least P? ”. As little tiger is a really smart guy, he can evaluate the answer quickly. 

You, Deep Monkey, can you work it out? Show your power!�
Input
The first line of input contains a single integer T (1 ≤ T ≤ 10) indicating the number of test cases. Then T test cases follow. 

Each test case is composed of two lines. The first line has two numbers N and P separated by a blank. N is an integer, satisfying 1 ≤ N ≤ 40. P is a floating number with at most 3 digits after the decimal point, and is in the range of [0, 1]. The second line has N numbers separated by blanks, which are the scores of each question. The score of each questions is an integer and in the range of [1, 1000]�
Output
For each test case, output only a single line with the answer.
Sample Input
1
3 0.5
1 2 3
Sample Output
3

题意刚开始有点弄不明白.

题意:

两个人A,B;

一共有n个科目,其中B写对一道题目的概率是0.5, 求使得A总得分不低于B总得分的概率 大于 p的  A的最低总分数。

看起来有点绕啊!!



思路:用dp[i][j] 来表示B前i个科目的得分为j的概率,通过B的概率来求得A的最低总得分.

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
double p;
double sc[45][50000];
int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int n;
		double p;
		scanf("%d %lf",&n,&p);
		memset(sc, 0, sizeof(sc)); 
		sc[0][0] = 1;
		int tmp;
		int max = 0;
		for(int i=0; i<n; i++)
		{
			scanf("%d",&tmp);
			for(int k=0; k<=max; k++)
			{
				if(sc[i][k]<=0)continue;
				sc[i+1][k+tmp] += sc[i][k]*0.5;
				sc[i+1][k] += sc[i][k]*0.5;
			}
			max += tmp;
		}
		double sum = 0.0;
		for(int i=0; i<=max; i++)
		{
			sum += sc[n][i];
			if(sum >= p)
			{
				printf("%d\n",i); break;
			}
		}	
	}
	return 0;
}

滚动数组优化:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
double p;
double sc[50000];
int main()
{
	int T;
	scanf("%d", &T);
	while(T--)
	{
		int n;
		double p;
		scanf("%d %lf",&n,&p);
		memset(sc, 0, sizeof(sc)); 
		sc[0] = 1;
		int tmp;
		int max = 0;
		for(int i=1; i<=n; i++)
		{
			scanf("%d",&tmp);
				max += tmp;
			for(int k=max; k>=0; --k)
			{
				sc[k] = sc[k]*0.5;
				if(k>=tmp)
			    sc[k] += sc[k-tmp]*0.5;
			}
		}
		double sum = 0.0;
		for(int i=0; i<=max; i++)
		{
			sum += sc[i];
			if(sum >= p)
			{
				printf("%d\n",i); break;
			}
		}	
	}
	return 0;
}


水波。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值