HDU 4815 Little Tiger vs. Deep Monkey


Little Tiger vs. Deep Monkey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 419    Accepted Submission(s): 149


Problem Description
A crowd of little animals is visiting a mysterious laboratory – The Deep Lab of SYSU.

“Are you surprised by the STS (speech to speech) technology of Microsoft Research and the cat face recognition project of Google and academia? Are you curious about what technology is behind those fantastic demos?” asks the director of the Deep Lab. “Deep learning, deep learning!” Little Tiger raises his hand briskly. “Yes, clever boy, that’s deep learning (深度学习/深度神经网络)”, says the director. “However, they are only ‘a piece of cake’. I won’t tell you a top secret that our lab has invented a Deep Monkey (深猴) with more advanced technology. And that guy is as smart as human!”

“Nani ?!” Little Tiger doubts about that as he is the smartest kid in his kindergarten; even so, he is not as smart as human, “how can a monkey be smarter than me? I will challenge him.”

To verify their research achievement, the researchers of the Deep Lab are going to host an intelligence test for Little Tiger and Deep Monkey.

The test is composed of N binary choice questions. And different questions may have different scores according to their difficulties. One can get the corresponding score for a question if he chooses the correct answer; otherwise, he gets nothing. The overall score is counted as the sum of scores one gets from each question. The one with a larger overall score wins; tie happens when they get the same score.

Little Tiger assumes that Deep Monkey will choose the answer randomly as he doesn’t believe the monkey is smart. Now, Little Tiger is wondering “what score should I get at least so that I will not lose in the contest with probability of at least P? ”. As little tiger is a really smart guy, he can evaluate the answer quickly.

You, Deep Monkey, can you work it out? Show your power!
 

Input
The first line of input contains a single integer T (1 ≤ T ≤ 10) indicating the number of test cases. Then T test cases follow.

Each test case is composed of two lines. The first line has two numbers N and P separated by a blank. N is an integer, satisfying 1 ≤ N ≤ 40. P is a floating number with at most 3 digits after the decimal point, and is in the range of [0, 1]. The second line has N numbers separated by blanks, which are the scores of each question. The score of each questions is an integer and in the range of [1, 1000]
 

Output
For each test case, output only a single line with the answer.
 

Sample Input
   
   
1 3 0.5 1 2 3
 

Sample Output
   
   
3
 

题目大意
给你T组case,每组case里面有一个n和一个p,n代表的是n个问题,p代表的是要保证能赢的概率。
下面n组样例是每个问题的分数,最后求出一个分数,使得这个分数能赢的概率是p。
看见题目本来想用二进制枚举来做,看来最近的几场比赛给我留下的印象深刻,然后发现自己逗比了,1<<40 肯定不是二进制枚举的思路。
明显是一个dp,还是一个以前做过很多次的完全背包问题........
思路不够开阔
#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;
int main ()
{
    int T;
    int n;
    double p;
    int sc[45];
    int dp[40005];
    scanf("%d",&T);
    while(T--)
    {

    int sum=0;
    memset(dp,0,sizeof(dp));
    dp[0]=1;
    scanf("%d%lf",&n,&p);
    for(int i=0;i<n;i++) {scanf("%d",&sc[i]); sum+=sc[i];}
    sort(sc,sc+n);

    for(int i=0;i<n;i++)
            for(int j=sum;j>=sc[i];j--)
                dp[j]+=dp[j-sc[i]];

//    for(int i=0;i<=sum;i++)
//    cout<<dp[i]<<endl;

    long long sum1=1LL<<n,sum2=0;
    for(int i=0;i<=sum;i++)
    {
        sum2+=dp[i];
        if((double)sum2/(double)sum1>=p)
        {
            printf("%d\n",i);
            break;
        }
    }
    }
}





  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值