1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1a​N1N​2a​N2… N​Ka​N​K
where K is the number of nonzero terms in the polynomial, N​iand a​N​i
​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K<⋯<N2<N​1≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:
3 3 3.6 2 6.0 1 1.6

大致思路就是第一次输入用n[ ],a[ ]存指数和系数,第二次输入的时候直接跟第一次的输入各项相乘,数组x[ ]下标存储最后相乘结果的指数,数组的值存储该指数的系数。

#include<iostream>
#include<iomanip>
using namespace std;
int main(){
	int i,j,k1,k2,n[20],count=0,n1;
	float a[20],x[2010]={},a1;
	cin>>k1;
	for(i=0;i<k1;i++){
		cin>>n[i]>>a[i];
	}
	cin>>k2;
	for(i=0;i<k2;i++){
		cin>>n1>>a1;
		for(j=0;j<k1;j++){
			if(x[n1+n[j]]==0){
				x[n1+n[j]]=a1*a[j];
				count++;
			}
			else{
				x[n1+n[j]]=x[n1+n[j]]+a1*a[j];
				//注意x[ ]为0时count的值应该减1
				if(x[n1+n[j]]==0)
					count--;
			}
		}
	}
	cout<<count;
	for(i=2009;i>=0;i--){
		if(x[i]!=0){
			cout<<" "<<i<<" "<<fixed<<setprecision(1)<<x[i];
		}
	}
	return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值