C-POJ-1426 Find The Multiple

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

BFS、DFS都可以

  1. BFS
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
typedef long long LL;
void BFS(int n){
    LL ans=1,b;
    queue <LL> a;
    a.push(ans);
    while(!a.empty()){
    b=a.front();
    a.pop();
    if(b%n==0){
        printf("%lld\n",b);
        return;
    }
    a.push(b*10);
    a.push(b*10+1);
    }
    return;
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)
            break;
        BFS(n);
    }
    return 0;
}
  1. DFS
#include<stdio.h>
#include<string.h>
#include<stdbool.h>
char ans[1005];
bool flag;
void dfs(int mod,int k,int n){
    if(k>20){
        ans[k]='\0';
        return;
    }
    if(mod==0){
        flag=true;
        return;
    }
    if(!flag){
        ans[k]='0';
        dfs((mod*10)%n,k+1,n);
    }
    if(!flag){
        ans[k]='1';
        dfs((mod*10+1)%n,k+1,n);
    }
    if(!flag){
        ans[k]='\0';
    }
}
int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)
            break;
        ans[0]='1';
        flag=false;
        dfs(1,1,n);
        printf("%s\n",ans);
        memset(ans,'\0',sizeof(ans));
    }
    return 0;
}

这题很简单,没啥说的。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值