Find The Multiple
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d & %I64u
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
本来以为又是高精度又要搜索,结果只是一道范围在ULL以内的DFS水题。
//
// main.cpp
// 简单搜索-E-Find The Multiple
//
// Created by 袁子涵 on 15/8/1.
// Copyright (c) 2015年 袁子涵. All rights reserved.
//
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
int n;
unsigned long long int m;
int dfs(int step,unsigned long long int num)
{
if (num%n==0) {
m=num;
return 1;
}
if (step>=19) {
return 0;
}
if(dfs(step+1, num*10))
return 1;
if(dfs(step+1, num*10+1))
return 1;
return 0;
}
int main(int argc, const char * argv[]) {
while (scanf("%d",&n)!=EOF) {
if (n==0) {
break;
}
dfs(0,1);
cout << m << endl;
}
return 0;
}