1003.Maximum Sequence

Time Limit: 4000/2000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)

Problem Description
Steph is extremely obsessed with “sequence problems” that are usually seen on magazines: Given the sequence 11, 23, 30, 35, what is the next number? Steph always finds them too easy for such a genius like himself until one day Klay comes up with a problem and ask him about it.

Given two integer sequences { ai } and { bi } with the same length n, you are to find the next n numbers of { ai }: an+1a2n . Just like always, there are some restrictions on an+1a2n : for each number ai, you must choose a number bk from { bi }, and it must satisfy ai ≤max{ ajj|bkj<i }, and any bk can’t be chosen more than once. Apparently, there are a great many possibilities, so you are required to find max{ 2nn+1ai } modulo 109+7 .

Now Steph finds it too hard to solve the problem, please help him.

Input
The input contains no more than 20 test cases.
For each test case, the first line consists of one integer n. The next line consists of n integers representing { ai }. And the third line consists of n integers representing { bi }.
1≤n≤250000, n≤ ai ≤1500000, 1≤ bi ≤n.

Output
For each test case, print the answer on one line: max{ 2nn+1ai } modulo 109+7。

Sample Input
4
8 11 8 5
3 1 4 2
Sample Output
27
Hint
For the first sample:
1. Choose 2 from { bi }, then a2a4 are available for a5 , and you can let a5 = a2 -2=9;
2. Choose 1 from { bi }, then a1a5 are available for a6 , and you can let a6 = a2 -2=9;

找规律的题目

//AC: 624MS 5220k
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
const int mod=1e9+7;
using namespace std;
typedef long long LL;
int a[3000020];
int c[230005];
int b[250005];
int main()
{
    int n;
    int t=0;
    while(scanf("%d",&n)!=EOF){
        LL ans=0,sum=0;
        t++;
        if(t>20)
            break;
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(int i=1;i<=n;i++)
            scanf("%d",&b[i]);
        sort(b+1,b+n+1);
        for(int i=n;i>0;i--){
            if(a[i]-i>=ans)
                ans=a[i]-i;
            c[i]=ans;
        }
        int max=-1;
        for(int i=1;i<=n;i++){
            if(c[b[i]]>max)
                a[n+i]=c[b[i]];
            else
                a[n+i]=max;
            if(a[n+i]-n-i>max)
                max=a[n+i]-n-i;
            sum+=a[n+i];
            if(sum>mod)
                sum%=mod;
        }
        printf("%lld\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值