[kuangbin带你飞]专题九 连通图 求桥(有坑点)

I - Caocao’s Bridges

Caocao was defeated by Zhuge Liang and Zhou Yu in the battle of Chibi. But he wouldn’t give up. Caocao’s army still was not good at water battles, so he came up with another idea. He built many islands in the Changjiang river, and based on those islands, Caocao’s army could easily attack Zhou Yu’s troop. Caocao also built bridges connecting islands. If all islands were connected by bridges, Caocao’s army could be deployed very conveniently among those islands. Zhou Yu couldn’t stand with that, so he wanted to destroy some Caocao’s bridges so one or more islands would be seperated from other islands. But Zhou Yu had only one bomb which was left by Zhuge Liang, so he could only destroy one bridge. Zhou Yu must send someone carrying the bomb to destroy the bridge. There might be guards on bridges. The soldier number of the bombing team couldn’t be less than the guard number of a bridge, or the mission would fail. Please figure out as least how many soldiers Zhou Yu have to sent to complete the island seperating mission.
Input
There are no more than 12 test cases.

In each test case:

The first line contains two integers, N and M, meaning that there are N islands and M bridges. All the islands are numbered from 1 to N. ( 2 <= N <= 1000, 0 < M <= N 2 )

Next M lines describes M bridges. Each line contains three integers U,V and W, meaning that there is a bridge connecting island U and island V, and there are W guards on that bridge. ( U ≠ V and 0 <= W <= 10,000 )

The input ends with N = 0 and M = 0.
Output
For each test case, print the minimum soldier number Zhou Yu had to send to complete the mission. If Zhou Yu couldn’t succeed any way, print -1 instead.
Sample Input
3 3
1 2 7
2 3 4
3 1 4
3 2
1 2 7
2 3 4
0 0
Sample Output
-1
4

题目大意:去掉一条边使得无向图不连通,去掉每一条边都需要相应的人数,求最少的人数。

求桥的模板题
但是有很多坑点
1.如果图本身就不是连通图,就不需要人
2.如果没有桥,输出-1
3.如果该桥的价值是一,也需要一个人
4.否则,就输出对应的人数

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1100000;
int n,m;
int head[maxn],cnt=0;
struct node
{
	int v,next,w;
}edge[maxn];
void add_edge(int u,int v,int w)
{
	edge[cnt].v=v;
	edge[cnt].w=w;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}
int low[2000],dfn[2000];
int bridge,cost[maxn];
int top,index;
void init()
{
	memset(head,-1,sizeof(head));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	memset(cost,0,sizeof(cost));
	bridge=0;
	cnt=top=index=0;
}
void tarjan(int u,int pre)
{
	low[u]=dfn[u]=++index;
	int v;
	int flag=0;
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		v=edge[i].v;
		if(v==pre&&flag==0)
		{
			flag++;;
			continue;
		}
		if(!dfn[v])
		{
			tarjan(v,u);
			low[u]=min(low[u],low[v]);
			if(low[v]>dfn[u])
			{
				bridge++;
				cost[bridge]=edge[i].w;
			}
		}
		else
		{
			low[u]=min(low[u],dfn[v]);
		}
	}
}
int main ()
{
	while(~scanf("%d%d",&n,&m))
	{
		if(n==0&&m==0)
		{
			break;
		}
		init();
		while(m--)
		{
			int xx,yy,zz;
			scanf("%d%d%d",&xx,&yy,&zz);
			add_edge(xx,yy,zz);
			add_edge(yy,xx,zz);
		}
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		if(!dfn[i])
		{
			tarjan(i,i);
			ans++;
		}
	}
	if(ans>1)
	{
		printf("0\n");
	}
	else
	{
		if(bridge==0)
		{
			printf("-1\n");
		}
		else
		{
			int minn=0x3f3f3f3f;
			for(int i=1;i<=bridge;i++)
			{
				minn=min(minn,cost[i]);
			}
			if(minn==0)
			{
				printf("1\n");
			}
			else
			printf("%d\n",minn);
		}
	}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值