算法训练 5-1最小公倍数

问题描述

  编写一函数lcm,求两个正整数的最小公倍数。

样例输入

一个满足题目要求的输入范例。

例:

3 5

样例输出

与上面的样例输入对应的输出。

例:这里写图片描述
数据规模和约定

输入数据中每一个数的范围。   

 例:两个数都小于65536。

思路:
最小公倍数=(a*b)/最大公约数
下图为求最大公约数的欧几里德算法:

这里写图片描述

代码如下:

package ALGO_148;
import java.util.Scanner;
public class Main {
    public static int lcm(int a,int b){
        int g=gcd(a,b);
        return a*b/g;
    }
    //求最大公约数
    public static int gcd(int a,int b){
        int n=a%b;
        while(n!=0){
            a=b;
            b=n;
            n=a%b;
        }
        return b;
    }
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        int a=cin.nextInt();
        int b=cin.nextInt();
        int res=lcm(a,b);
        System.out.print(res);
    }
}

方法二:(使用递归法)

package sf_8;
import java.util.Scanner;
public class Main {
    public static int lcm(int a,int b){
        int g=gcd(a,b);
        return a*b/g;
    }
    //求最大公约数
    public static int gcd(int a,int b){
        if(b==0)
            return a;
        return gcd(b,a%b);
    }
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        int a=cin.nextInt();
        int b=cin.nextInt();
        int res=lcm(a,b);
        System.out.print(res);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值