hdu1714RedField 椭圆扇形面积公式

RedField

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1118    Accepted Submission(s): 413


Problem Description
As the graph you see below, we named the red part "RedField".The read part is the intersection of an ellipse and a triangle.Now, 8600's not good at math, so he wants you to help him calculate the area of the "RedField".
 

Input
The first line of input contains n, the number of test cases. n lines follow.Each test case contains four numbers a, b, x, y(0 < b <= a <= x),and a is the lenth of OA, b is the lenth of OB,and x, y representing the coordinate of the point P.
 

Output
For each test case, output the area of the "RedField",accurate up to 2 decimal places.
 

Sample Input
  
  
1 1.00 1.00 2.00 2.00
 

Sample Output
  
  
0.39
 

Source


重点就是一个扇形公式。
#include<stdio.h>
#include<cmath>
#include<iostream>
using namespace std;
struct epllies
{
    double a,b;
}p;
struct point
{
    double x,y;
}q;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double k,X1,Y1,S,m,n;
        scanf("%lf %lf %lf %lf",&p.a,&p.b,&q.x,&q.y);
        k=q.y/q.x;
        X1=sqrt((p.a*p.a*p.b*p.b)/(p.b*p.b+p.a*p.a*k*k));

        S=(p.a*p.b*acos(X1/p.a))/2;      ///椭圆扇形 S=(a*b*arccos(x/a))/2

        printf("%.2lf\n",S);
    }
}

 
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值