FZU 2150 Fire Game(I)

Problem 2150 Fire Game

Accept: 2332    Submit: 8128
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2


题意:给一个n*m的矩阵  #带点草  .代表空地  两个小孩在两个地方(两个地方可以相同)同时放火,问最少多少时间可以把所有草地烧完。火每一分钟向周围4个方向的草地扩撒一次。
思路:双BFS  即一开始就往队列中放两个初始点即可。最后遍历一遍,查找是否有没被烧的,如果都被烧了,则最长的时间。
一开始可以用一个pair【】存储所有草地的坐标,方便后面的注意枚举两个放火点
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<string.h>
#include<queue>
#include<vector>
using namespace std;
#define maxn 15
#define P(a,b) make_pair(a,b)
bool vis[maxn][maxn];
int n,m;
char maps[maxn][maxn];
int step[maxn][maxn];
int go[4][2]={0,1,0,-1,1,0,-1,0};
int bfs(int a,int b,int c,int d)
{
	memset(vis,0,sizeof vis);
	memset(step,-1,sizeof step);
	queue<pair<int ,int >>q;
	q.push(P(a,b));
	q.push(P(c,d));
	vis[a][b]=true;
	vis[c][d]=true;
	step[a][b]=0;
	step[c][d]=0;
	while(!q.empty())
	{
		pair<int ,int >p;
		p=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			int fx=p.first+go[i][0];
			int fy=p.second+go[i][1];
			if(fx>=0&&fx<n&&fy>=0&&fy<m)
			{
				if(!vis[fx][fy]&&maps[fx][fy]=='#')
				{
					vis[fx][fy]=true;
					step[fx][fy]=step[p.first][p.second]+1;
					q.push(P(fx,fy));
				}
			}
		}
	}
	int ans=0;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<m;j++)
		{
			if(maps[i][j]=='#')
			{
				if(step[i][j]==-1)return 10000;
				ans=max(ans,step[i][j]);
			}
		}
	}
	return ans;
}
int main()
{
	int t;
	scanf("%d",&t);
	for(int k=1;k<=t;k++)
	{
		scanf("%d%d",&n,&m);
		pair<int,int>p[maxn*maxn];
		int tot=0;
		for(int i=0;i<n;i++)
		{
			scanf("%s",maps[i]);
			for(int j=0;j<m;j++)
			{
				if(maps[i][j]=='#')
				{
					p[tot].first=i;
					p[tot].second=j;
					tot++;
				}
			}
		}
		int ans=10000;
		for(int i=0;i<tot;i++)
		{
			for(int j=i;j<tot;j++)
			{
				ans=min(ans,bfs(p[i].first,p[i].second,p[j].first,p[j].second));
			}
		}
		if(ans==10000)ans=-1;
		printf("Case %d: %d\n",k,ans);
	}
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值