FZU - 2150 Fire Game (双向BFS+判断连通块)

Problem 2150 Fire Game 
Time Limit: 1000 mSec    Memory Limit : 32768 KB
Problem Description
Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)
You can assume that the grass in the board would never burn out and the empty grid would never get fire.
Note that the two grids they choose can be the same.
Input
The first line of the date is an integer T, which is the number of the text cases.
Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.
1 <= T <=100, 1 <= n <=10, 1 <= m <=10
Output
For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.
Sample Input
4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#

#.# 

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0

Case 4: 2


题意大致是说选择两个点作为起火点,然后会将四周的草逐步点燃,问如果能全部烧光求最短时间,否则输出-1.

题目的范围不大,直接枚举所有可能的点的组合作为起点BFS,注意可以选取两个相同的点作为起点。

记录队列中最后一个出队的节点一定是整个联通块最后烧完的。之后再判断是否还有其他连通块,如果不存在其他的连通块说明选取的起始点符合要求,接下来只需要继续枚举选出符合要求中最小的答案。

#include <iostream>
#include <cstring>
#include <queue>
#define inf 0x3f3f3f3f
using namespace std;
struct node{
	int x,y,step;
};
int next[4][2] = {0,1,0,-1,1,0,-1,0};
int m,n,k;
bool check (char map[20][20])//检查当前地图是否存在其他连通
{
	for (int i = 0;i < m; i++){
		for (int j = 0;j < n; j++){
			if (map[i][j] == '#'){
				return false;
			}
		}
	}	
	return true;
}
int bfs(char map[20][20],node a,node b)//双起点的BFS搜索 
{
	int ans = 0;
	queue<node> Q;
	Q.push(a);
	Q.push(b);
	map[a.x][a.y] = '.';
	map[b.x][b.y] = '.';
	while (!Q.empty()){
		
		node k = Q.front();
		Q.pop();
		ans = k.step;//队列中最后一个节点的step一定是扩散该连通块的步长,这里ans其实按照顺序记录下了每一个节点的step。
		for (int i = 0;i < 4; i++){
			node P;
			P.x = k.x+next[i][0];
			P.y = k.y+next[i][1];
			P.step = k.step+1;
			
			if (P.x < 0 || P.y < 0 || P.x >= m || P.y >= n){
				continue;
			}
			if (map[P.x][P.y] == '#'){
				map[P.x][P.y] = '.';
				Q.push(P);
			}

		}
	}
	return ans;
}
int main ()
{
	scanf ("%d",&k);
	int pp = 0;
	for (pp = 1;pp <= k;pp++){
		int ver[20][20] = {0},book[105][105] = {0};
		scanf ("%d%d",&m,&n);
		char map[20][20],option[20][20];
		getchar ();
		for (int i = 0;i < m; i++){
			scanf ("%s",map[i]);
		}
		int min = 999999,ans = 9999999;
		node a,b;
		for (int i = 0;i < m; i++){//枚举第一个着火点 
			for (int j = 0;j < n; j++){
				if (map[i][j] == '#'){
					int cut,cur;
					for (cur = i;cur < m; cur++){//枚举第二个着火点(注意可以与第一个点相同)
						if (cur == i)	cut = j;//枚举起点需要稍微控制,保证不和以前枚举过的组合重复
						else			cut = 0;
						for (cut ;cut < n;cut++ ){
							if (map[cur][cut] == '#'){
								a.x = i;
								a.y = j;
								a.step = 0;
								b.x = cur;
								b.y = cut;
								b.step = 0;
								for (int k = 0;k < m; k++){
									strcpy(option[k],map[k]);//使用中间数组以达到map数组可多次使用的目的 
								}
								int t = bfs(option,a,b);//搜索过程中将已经搜索过的点置空,等于该连通块不存在
								min = min < t ? ans : t;
								if (!check(option)){//检查当前地图是否存在其他连通块,若存在则min答案无效
									min = 999999;
								}
								ans = min < ans ? min : ans;//ans只会保存有效的min数值中的最小值 
							}
						}
					}
				}
			}
		}
		
		if (ans != 999999){
			printf ("Case %d: %d\n",pp,ans);
		}
		else{
			printf ("Case %d: -1\n",pp);
		}
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值