poj 1511 Invitation Cards(SPFA)(矩阵以及邻接表对比)

Invitation Cards
Time Limit: 8000MS
Memory Limit: 262144K
Total Submissions: 27784
Accepted: 9263

Description

In the age of television, not many people attend theater performances. Antique Comedians of Malidinesia are aware of this fact. They want to propagate theater and, most of all, Antique Comedies. They have printed invitation cards with all the necessary information and with the programme. A lot of students were hired to distribute these invitations among the people. Each student volunteer has assigned exactly one bus stop and he or she stays there the whole day and gives invitation to people travelling by bus. A special course was taken where students learned how to influence people and what is the difference between influencing and robbery.

The transport system is very special: all lines are unidirectional and connect exactly two stops. Buses leave the originating stop with passangers each half an hour. After reaching the destination stop they return empty to the originating stop, where they wait until the next full half an hour, e.g. X:00 or X:30, where 'X' denotes the hour. The fee for transport between two stops is given by special tables and is payable on the spot. The lines are planned in such a way, that each round trip (i.e. a journey starting and finishing at the same stop) passes through a Central Checkpoint Stop (CCS) where each passenger has to pass a thorough check including body scan.

All the ACM student members leave the CCS each morning. Each volunteer is to move to one predetermined stop to invite passengers. There are as many volunteers as stops. At the end of the day, all students travel back to CCS. You are to write a computer program that helps ACM to minimize the amount of money to pay every day for the transport of their employees.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case begins with a line containing exactly two integers P and Q, 1 <= P,Q <= 1000000. P is the number of stops including CCS and Q the number of bus lines. Then there are Q lines, each describing one bus line. Each of the lines contains exactly three numbers - the originating stop, the destination stop and the price. The CCS is designated by number 1. Prices are positive integers the sum of which is smaller than 1000000000. You can also assume it is always possible to get from any stop to any other stop.

Output

For each case, print one line containing the minimum amount of money to be paid each day by ACM for the travel costs of its volunteers.

Sample Input

2
2 2
1 2 13
2 1 33
4 6
1 2 10
2 1 60
1 3 20
3 4 10
2 4 5
4 1 50

Sample Output

46
210
题意:

给出n个点和n条有向边,求所有点到源点1的来回最短路之和(保证每个点都可以往返源点1)

解题思路:这个数据范围太大,明显的不能用floyd,dijstra,bellman-ford这些算法,

用spfa的话也不能用邻接矩阵存,因为点太多了,所以采用spfa的邻接表存储搞定

稍微有点注意的地方是,来回之和只需要将所有的边反向再从1到所有点求最短路就是他们的最短回路


首先为第一次做TLE的SPFA的矩阵存储

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN=1000010;
const int INF=0x7f7f7f7f;
struct edge
{
    int s,e,w;
    edge(int a=0,int b=0,int c=0):s(a),e(b),w(c) {}
};

int dis[MAXN],n,m;
bool inque[MAXN];
vector<vector<edge> > edges(MAXN),edges_fan(MAXN);
void SPFA(int v0)
{
    memset(inque, false, sizeof(inque));
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[v0] = 0;
    queue <int> q;
    q.push(v0);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        inque[u] = false;			//出队列为false
        int sz = edges[u].size();    //u出度的个数
        for(int i = 0; i < sz; i++)
        {
            int v = edges[u][i].e;
            int w = edges[u][i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(!inque[v])
                {
                    q.push(v);
                    inque[v] = true;//入队列为true
                }
            }
        }
    }

}
void SPFA_fan(int v0)
{
    memset(inque, false, sizeof(inque));
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[v0] = 0;
    queue <int> q;
    q.push(v0);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        inque[u] = false;
        int sz = edges_fan[u].size();
        for(int i = 0; i < sz; i++)
        {
            int v = edges_fan[u][i].e;
            int w = edges_fan[u][i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(!inque[v])
                {
                    q.push(v);
                    inque[v] = true;
                }
            }
        }
    }

}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{

		scanf("%d%d",&n,&m);//n个点  m条有向边
		int a,b,c;
		for(int i=1;i<=n;i++)
		{
			edges[i].clear();   //因为要求正反来回和 
			edges_fan[i].clear();
		}
		edge s,s1;
		
		for(int i=0;i<m;i++)
		{
			scanf("%d%d%d",&s.s,&s.e,&s.w);
			edges[s.s].push_back(s);
			s1.s=s.e;
			s1.e=s.s;
			s1.w=s.w;
			edges_fan[s1.s].push_back(s1);

		}
		SPFA(1);
		long long  sum=0;
		for(int i=2;i<=n;i++)
			sum+=dis[i];
		SPFA_fan(1);
		for(int i=2;i<=n;i++)
			sum+=dis[i];
			printf("%lld\n",sum);
	}
	return 0;
}

接下来是AC代码  SPFA的邻接表存储 不仅时间上大大缩减  同时代码量也较为简洁

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<string.h>
#include<queue>
using namespace std;
const int MAXN=1000010;
const int INF=0x7f7f7f7f;
struct edge
{
    int next,e,w;
}edges[2][MAXN];//用二维数组表示 0表示正向 1表示反向
int head[2][MAXN];
int dis[MAXN],n,m;
bool inque[MAXN];
void SPFA(int start)
{
    memset(inque, false, sizeof(inque));
    for(int i = 1; i <= n; i++) dis[i] = INF;
    dis[1] = 0;
    queue <int> q;
    q.push(1);
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        inque[u] = false;               //出队列则false
        for(int i = head[start][u]; i!=-1; i=edges[start][i].next)//邻接表的遍历
        {
            int v = edges[start][i].e;
            int w = edges[start][i].w;
            if(dis[v] > dis[u] + w)
            {
                dis[v] = dis[u] + w;
                if(!inque[v])			//如果不在队列就将其加入队列中去
                {
                    q.push(v);
                    inque[v] = true;     //入队列则true
                }
            }
        }
    }

}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int a,b,c;
		scanf("%d%d",&n,&m);//n个点  m条有向边
		for(int i=1;i<=n;i++)
		{
			head[0][i]=head[1][i]=-1;//0代表正  1代表反
		}
		for(int i=0;i<m;i++)
		{

			scanf("%d%d%d",&a,&b,&c);
			edges[0][i].e=b;
			edges[0][i].w=c;
			edges[0][i].next=head[0][a];//邻接表存储
			head[0][a]=i;
			edges[1][i].e=a;//反向存储
			edges[1][i].w=c;
			edges[1][i].next=head[1][b];
			head[1][b]=i;

		}
		SPFA(0);
		long long  sum=0;
		for(int i=2;i<=n;i++)
			sum+=dis[i];
		SPFA(1);
		for(int i=2;i<=n;i++)
			sum+=dis[i];
		printf("%lld\n",sum);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值