HDU1005 规律题

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1005

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
(1 <= A, B <= 1000, 1 <= n <= 100,000,000).给出A,B,N,计算结果。

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
思路:一看这题,感觉暴力肯定会超时。那么狠可能是规律题。因为是mod7,所以f(n)有0-6 7钟可能,f(n+1)也是7种,所以f(n+2)最多49种。所以49之后就是规律。
#include<stdio.h>
using namespace std;
int main()
{
    int a, b, n;
    int s[101] = { 0 ,1,1};
    while (~scanf("%d%d%d", &a, &b, &n) && (a + b + n))
    {
        int m = 0,i;
            for (i = 3; i < 100; i++)
        {
            s[i] = (a*s[i - 1] + b*s[i - 2])%7;
            if (s[i] == 1 && s[i - 1] == 1)
                break;
        }
            m = i - 2;//周期
            n %= m;
            if(n!=0)
            printf("%d\n", s[n]);
            else
                printf("%d\n", s[i-2]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值