nyoj 546 难度4 第五届河南省程序设计大赛

多重背包优化----Divideing Jewels

时间限制:1000 ms  |  内存限制:65535 KB

难度:4

描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入

Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000. 
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line. 

输出

For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case. 

样例输入

1 0 1 2 0 0 0 0 2 0

1 0 0 0 1 1 0 0 0 0

0 0 0 0 0 0 0 0 0 0

样例输出

#1:Can't be divided.

#2:Can be divided.

来源

第五届河南省程序设计大赛

上传者

rihkddd

题意

给你价值从1到10,每种珠宝的个数,问Rose和Mary两姐妹能不能平均分,都得到相同价值的珠宝。

输入

珠宝总个数小于10000. 
输入 "0 0 0 0 0 0 0 0 0 0";结束

输出

输出 "#k:", k为测试数据的组数 如果能分输出"Can be divided." 不能分输出 "Can't be divided.".

思路:对于每种珠宝要是偶数个只保留2个用来凑和,多余的直接平分,要是奇数个只保留1个凑和,其余的偶数个可以直接平分。记录保留的价值之和是奇则一定不可能平分,是偶数还要用01背包的算法计算一下如果dp[sum/2]==sum;则一定能平分,预处理完就类似于两兄弟分邮票这道题了。

//根据题意巧妙化为01背包来做
#include<stdio.h>
#include<string.h>
int dp[100],a[15];
int main()
{
	int kase=1;
	while(1)
	{
		int x,p=1,flag=0,m,sum=0,t=0;
		memset(dp,0,sizeof dp);
		memset(a,0,sizeof a);
		for(int i=1;i<=10;i++)
		{
			scanf("%d",&x);
			if(x==0) t++;
			else{
				if(x%2==0){
					a[p++]=i;a[p++]=i;
					sum+=i*2;
				}
				else{
					a[p++]=i;sum+=i;
				}
			}
		}
		if(t==10)return 0;
		if(sum%2==0){
		    m=sum/2;
			flag=1;
			for(int i=1;i<p;i++){
				for(int j=m;j>=a[i];j--)
				    if(dp[j]<dp[j-a[i]]+a[i])
				    dp[j]=dp[j-a[i]]+a[i];
			}
		}
		if(flag&&dp[m]==m) printf("#%d:Can be divided.\n",kase++);
		else printf("#%d:Can't be divided.\n",kase++);
	}
}
 

一般的多重背包优化

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int m;
int a[10005],dp[100007];
void zero(int cost,int value){
	for(int i=m;i>=cost;i--)
		dp[i]=max(dp[i],dp[i-cost]+value);
}
void complete(int cost,int value){
	for(int i=cost;i<=m;i++)
		dp[i]=max(dp[i],dp[i-cost]+value);
}
void multi(int cost,int value,int num){
	if(num*cost>=m)
	{
		complete(cost,value);
		return ;
	}
	int k=1;
	while(k<num)
	{//不能选无线多个就按01背包来做
		zero(k*cost,k*value);
		num-=k;
		k*=2;
	}
	zero(num*cost,num*value);
}
int main()
{
	int kase=1;
	while(1){
		int sum=0;
		int flag=0;
		memset(dp,0,sizeof dp);
		for(int i=1;i<=10;i++)
		{
			scanf("%d",&a[i]);
			sum+=a[i]*i;
		}
		if(sum==0)return 0;
		if(sum%2==0){
			m=sum/2;
			flag=1; 
			for(int i=1;i<=10;i++)
			{
				multi(i,i,a[i]);
			}
		} 
		if(flag&&dp[m]==m){
			printf("#%d:Can be divided.\n",kase++);
		}
		else{
			printf("#%d:Can't be divided.\n",kase++);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
东南亚位于我国倡导推进的“一带一路”海陆交汇地带,作为当今全球发展最为迅速的地区之一,近年来区域内生产总值实现了显著且稳定的增长。根据东盟主要经济体公布的最新数据,印度尼西亚2023年国内生产总值(GDP)增长5.05%;越南2023年经济增长5.05%;马来西亚2023年经济增速为3.7%;泰国2023年经济增长1.9%;新加坡2023年经济增长1.1%;柬埔寨2023年经济增速预计为5.6%。 东盟国家在“一带一路”沿线国家中的总体GDP经济规模、贸易总额与国外直接投资均为最大,因此有着举足轻重的地位和作用。当前,东盟与中国已互相成为双方最大的交易伙伴。中国-东盟贸易总额已从2013年的443亿元增长至 2023年合计超逾6.4万亿元,占中国外贸总值的15.4%。在过去20余年中,东盟国家不断在全球多变的格局里面临挑战并寻求机遇。2023东盟国家主要经济体受到国内消费、国外投资、货币政策、旅游业复苏、和大宗商品出口价企稳等方面的提振,经济显现出稳步增长态势和强韧性的潜能。 本调研报告旨在深度挖掘东南亚市场的增长潜力与发展机会,分析东南亚市场竞争态势、销售模式、客户偏好、整体市场营商环境,为国内企业出海开展业务提供客观参考意见。 本文核心内容: 市场空间:全球行业市场空间、东南亚市场发展空间。 竞争态势:全球份额,东南亚市场企业份额。 销售模式:东南亚市场销售模式、本地代理商 客户情况:东南亚本地客户及偏好分析 营商环境:东南亚营商环境分析 本文纳入的企业包括国外及印尼本土企业,以及相关上下游企业等,部分名单 QYResearch是全球知名的大型咨询公司,行业涵盖各高科技行业产业链细分市场,横跨如半导体产业链(半导体设备及零部件、半导体材料、集成电路、制造、封测、分立器件、传感器、光电器件)、光伏产业链(设备、硅料/硅片、电池片、组件、辅料支架、逆变器、电站终端)、新能源汽车产业链(动力电池及材料、电驱电控、汽车半导体/电子、整车、充电桩)、通信产业链(通信系统设备、终端设备、电子元器件、射频前端、光模块、4G/5G/6G、宽带、IoT、数字经济、AI)、先进材料产业链(金属材料、高分子材料、陶瓷材料、纳米材料等)、机械制造产业链(数控机床、工程机械、电气机械、3C自动化、工业机器人、激光、工控、无人机)、食品药品、医疗器械、农业等。邮箱:market@qyresearch.com

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值