NYOJ 546 Divideing Jewels

描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入
Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000. 
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line. 
输出
For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 
Output a blank line after each test case. 
样例输入
1 0 1 2 0 0 0 0 2 0
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0
样例输出
#1:Can't be divided.
#2:Can be divided.
 
   
这道题比较简单,但让我做了很长时间,错的让我很费解,很无语。。。。。
正确:
#include<stdio.h>
#include<string.h>
int val[15];
int dp[51000];
int main()
{
    int sum,i,j,v,k;
    int t = 1;
    for(t;;t++)
    {
        memset(dp,0,sizeof(dp));
        sum = 0;
        for(i=1;i<=10;i++)
        {
            scanf("%d",&val[i]);
            sum += i*val[i];
        }
        if(sum == 0)
        break;
        if(sum&1)
        {
            printf("#%d:Can't be divided.\n\n",t);
            continue;
        }
        sum>>=1;
        dp[0] = 1;
        for(i=1;i<=10;i++)
        for(j=1;j<=val[i];j++)
        for(v=sum;v>=i;v--)
        if(dp[v-i])
        dp[v] = 1;
        if(dp[sum])
        printf("#%d:Can be divided.\n\n",t);
        else
        printf("#%d:Can't be divided.\n\n",t);
    }
    return 0;
}
        

错误:求解释。。。
#include<stdio.h>
#include<string.h>
int val[15];
int dp[51000];
int main()
{
    int sum,i,j,v,k;
    int t = 1;
    while(1) 
    {
        memset(dp,0,sizeof(dp));
        sum = 0;
        for(i=1;i<=10;i++)
        {
            scanf("%d",&val[i]);
            sum += i*val[i];
        }
        if(sum == 0)
        break;
        if(sum&1)
        {
            printf("#%d:Can't be divided.\n\n",t);
            continue;
        }
        sum>>=1;
        dp[0] = 1;
        for(i=1;i<=10;i++)
        for(j=1;j<=val[i];j++)
        for(v=sum;v>=i;v--)
        if(dp[v-i])
        dp[v] = 1;
        if(dp[sum])
        printf("#%d:Can be divided.\n\n",t);
        else
        printf("#%d:Can't be divided.\n\n",t);
        t ++;
    }
    return 0;
}
        



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值