nyoj546 多重背包,有优化

Divideing Jewels

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述

Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

输入
Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000.
The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line.
输出
For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
Output a blank line after each test case.
样例输入
1 0 1 2 0 0 0 0 2 0
1 0 0 0 1 1 0 0 0 0
0 0 0 0 0 0 0 0 0 0
样例输出
#1:Can't be divided.

#2:Can be divided.

题目大意是问有面值1-10的珍珠各有一定数量,问能均分成两份价值一样的吗。

解题思路

  比较明显的多重背包,求出总价值/2,看这些珍珠能不能装满价值为sum/2的背包,利用一个多重背包的计数可以避免三次循环,因为要把i个价值相同的合并成一个物品放入

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int dp[100005];
int count[100005];
int main(){
	int a[12];
	bool f=true;
	int test=1;
	while(true){
		f=false;
		int sum=0;
		for (int i=1;i<=10;i++){
			cin>>a[i];
			if (a[i]!=0) f=true;
			sum+=(a[i]*i);
		}
		if(!f) break;
		if (sum%2!=0){
			printf("#%d:Can't be divided.\n\n",test++);
			continue;
		}
		//cout<<sum<<endl;
		sum=sum/2; 
		memset(dp,0,sizeof(dp));
		dp[0]=1;
		for (int i=1;i<=10;i++){
			if (a[i]==0) continue;
			memset(count,0,sizeof(count));
			for (int j=i;j<=sum;j++){
				//一定要先判断dp[j]==0,如果等于1就不用消耗当前面值  count计数用了多少个
				if (dp[j]==0&&dp[j-i]==1&&count[j-i]+1<=a[i]){
					dp[j]=1;
					count[j]=count[j-i]+1;
				}
			}
		}
		if (dp[sum]==1) 
				printf("#%d:Can be divided.\n\n",test++);
		else 	printf("#%d:Can't be divided.\n\n",test++);
			 //cout<<endl;
	}
	cout<<endl;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值