数据结构实验之二叉树四:还原二叉树

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。

Input
输入数据有多组,每组数据第一行输入 1 个正整数 N(1 <= N <= 50) 为树中结点总数,随后 2 行先后给出先序和中序遍历序列,均是长度为 N 的不包含重复英文字母 ( 区分大小写 ) 的字符串。

Output
输出一个整数,即该二叉树的高度。
Example Input
9 
ABDFGHIEC
FDHGIBEAC
Example Output
5
 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
    char data;
    struct node *lc,*rc;
}bitree;
int max;
bitree * create(int zlen,char qst[],char zst[])
{
    if(zlen<=0)
        return NULL;
    int i;
    bitree * t;
    t=(bitree *)malloc(sizeof(bitree));
    t->data=qst[0];
    for(i=0;i<zlen;i++)
    {
        if(qst[0]==zst[i])
            break;
    }
    t->lc=create(i,qst+1,zst);
    t->rc=create(zlen-i-1,qst+i+1,zst+i+1);
    return t;
}
void preshow(int count,bitree *t)
{
    int k;
    if(t)
    {
        if(count==0)
            count=1;
        k=count;
        if(k>max)
            max=k;
        preshow(++count,t->lc);
        preshow(++k,t->rc);
    }
}
int main()
{
    int zlen;
    char qst[51],zst[51];
    bitree * tree;
    while(scanf("%d",&zlen)!=EOF)
    {
        max=0;
        scanf("%s%s",qst,zst);
        zlen=strlen(zst);
        tree=create(zlen,qst,zst);
        preshow(0,tree);
        printf("%d\n",max);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值