动态规划9Monkey and Banana

Monkey and Banana

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 24   Accepted Submission(s) : 13
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input

The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

Sample Input

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342
AC代码

//变形的最长递增子序列
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

_int64 k[100007];

long long max1(long long a,long long b)
{
	return a > b ? a : b;
}

struct block
{
	block(int a, int b, int c)
	{
		length = a;
		width = b;
		height = c;
	}
	int length;
	int width;
	int height;
};


bool cmp(block a, block b)
{
	return a.length > b.length;
}

int main()
{
	int n;
	int a, b, c;
	int t = 0;
	vector<block>m;
	while (cin >> n, n)
	{
		memset(k, 0, sizeof(k));
		
		for (int i = 0; i != n; ++i)
		{
			cin >> a >> b >> c;
			m.emplace_back(block(a, b, c));
			m.emplace_back( block(a, c, b));
			m.emplace_back( block(b, a, c));
			m.emplace_back( block(b, c, a));
			m.emplace_back( block(c, a, b));
			m.emplace_back( block(c, b, a));//将一块砖的每一种形态都保存下来
		}
		sort(m.begin(), m.end(), cmp);//按长度排序,接着找宽度从后往前的最长递增子序列
		_int64 maxb;
		_int64 maxa = 0;
		for (int i = m.size() - 1; i >= 0; --i)
		{
			maxb = 0;
			for (int j = i + 1; j < m.size(); ++j)
			{
				if(m[i].width > m[j].width&&m[i].length > m[j].length)
					maxb = max1(maxb, k[j]);
			}
			k[i] = maxb + m[i].height;
			if (k[i] > maxa)
				maxa = k[i];
		}
		cout << "Case " << ++t << ": " << "maximum height" << " = " << maxa << endl;
		m.clear();
	}
	system("pause");
	return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值