并查集

/*
Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.
Input
* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.
Output
Print the output from each of the count operations in the same order as the input file.
Sample Input
6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
Sample Output
1
0
2*/

//带权并查集

#include<iostream>
#define maxn 1000
using namespace std;

struct node
{
	int father;
	int sum;//所在堆的数量
	int under;//在x下方的数量
}nodes[maxn];



int find(int x)
{
	if (x == nodes[x].father)
		return x;
	else
	{
		int fa = nodes[x].father;
		nodes[x].father = find(nodes[x].father);
		nodes[x].under += nodes[fa].under;//路径压缩
	}
	return nodes[x].father;
}



int main() {
	int p;
	cin >> p;
	for (int i = 0; i <= 9; ++i)
	{
		nodes[i].father = i;
		nodes[i].sum = 1;
		nodes[i].under = 0;
	}
	for (int i = 0; i != p; ++i)
	{
		char ch;
		cin >> ch;
		if (ch == 'M')
		{
			int x, y;
			cin >> x >> y;
			int fx = find(x);
			int fy = find(y);
			nodes[fx].father = fy;
			nodes[fx].under += nodes[fy].sum;
			nodes[fy].sum += nodes[fx].sum;
		}
		else
		{
			int x;
			cin >> x;
			find(x);
			cout << nodes[x].under << endl;
		}
	}
	system("pause");
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值