Cube Stacking(带权并查集)

Cube Stacking

题目链接

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.

  • In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
  • In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.
    Write a program that can verify the results of the game.

Input

  • Line 1: A single integer, P
  • Lines 2…P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M’ for a move operation or a ‘C’ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.
    Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

题目大意

题目的大概意思是给了一堆方块,有两种操作
M X,Y将把含有X数据的盒子放在含有Y数据的盒子上
C X是询问X下面有多少方块
我们把根节点当做为每个堆中最底层的那一个方块;

代码实现

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<math.h>
#include<string>
#include<cstring>
using namespace std;
const int maxn=3e4+5;
int f[maxn],dis[maxn],sum[maxn];
//f[]代表父亲节点,dis[]代表距离父亲结点的距离==下面的方块个数,sum[]代表所在集合有多少方块
void init()
{
	for(int i=1;i<=maxn-1;i++)
	{
		f[i]=i;
		dis[i]=0;
		sum[i]=1;
	}
}
int fdroot(int x)//寻找的同时更新dis数组
{
	if(x==f[x])
		return x;
 	else
 	{
 		int y=f[x];
 		f[x]=fdroot(f[x]);
 		dis[x]+=dis[y];//更新距离数组
 		return f[x];
	 }
} 
void join(int x,int y)
{
 	int rx=fdroot(x);
 	int ry=fdroot(y);
 	if(rx!=ry)
 	{
 		f[rx]=ry;
 		dis[rx]+=sum[ry];
 		//将x所在的集合放在y所在的集合上,所以x到新的根节点要加上所有的y集合的个数
 		sum[ry]+=sum[rx];
 		//两个集合合并和
	 }
}
int main()
{
	int n,m;
	cin>>n;
	init();
	char s;
	int a,b;
	for(int i=1;i<=n;i++)
	{
		cin>>s;
		if(s=='M')
		{
			cin>>a>>b;
			join(a,b);
		}
		if(s=='C')
		{
			cin>>a;
			fdroot(a);//更新dis数组
			cout<<dis[a]<<endl;
		}
	}
	return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值