PAT 1037 Magic Coupon python解法

1037 Magic Coupon (25 分)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​​C,N​P​​ ≤10​5​​ , and it is guaranteed that all the numbers will not exceed 2​30​​ .

Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43

题意:在一个神秘商店中,发放一些优惠券,你可以使用这些优惠券获得n倍的产品价值, 对于优惠券{ 1 2 4 −1 }和产品价值{ 7 6 −2 −3 }来说,优惠券x产品价值=获得的优惠,如果想获得最大产品价值,可以将最大的优惠券用在最大的产品价值上,比如4x7=28,依次选择最大的,最终得到4x7+2x6+(-1)*(-3)=43,需要注意的是,如果优惠券和产品价值的乘积是一个负数,你将会支付费用给商店。

解题思路:要获得最大利益,肯定是先排序,但其中有负数和正数,后面不好处理,想到可以将正负数分离,分别保存。进行循环的时候,要注意优惠券个数和产品个数不一定相等,加一个判断即可解决。还有,对两个负数相乘来说,最小的反而是获利最大的。

n = int(input())
coupon = list(map(int,input().split()))
m = int(input())
products = list(map(int,input().split()))
#n = 4
#coupon = [1, 2, 4, -1]
#m = 4
#products = [7, 6,-2,-3]
coupon.sort(reverse = True)
products.sort(reverse = True)
positive_coupon = [i for i in coupon if i > 0]
negative_coupon = [i for i in coupon if i < 0]
positive_products = [i for i in products if i > 0]
negative_products = [i for i in products if i < 0]

get = 0
length = min(len(positive_products),len(positive_coupon))
for i in range(length):
    get +=  positive_products[i] * positive_coupon[i]
    
length = min(len(negative_coupon),len(negative_products))
for i in range(-length,0):
    get += negative_coupon[i] * negative_products[i]
print(get)
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值