PAT 1077 Kuchiguse python解法

1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality:

Itai nyan~ (It hurts, nyan~)

Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3
Itai!
Ninjinnwaiyada T_T
T_T
Sample Output 2:
nai

题意:输出几个字符串的最长公共后缀,如没有则输出nai。

解题思路:把字符串倒序,变成求最长的公共前缀
先获取最短的字符串的长度minn,将每个字符串的前minn个字符拿出来,存到一个二维列表kuchiguse中,将kuchiguse中每一个一维列表变成集合,如果集合中的元素只有一个,说明是公共的字符,用out将公共字符存起来,最后判断out的长度,非0则倒序输出,否则输出nai。
1.把输入的字符串倒序存到列表l中,同时将字符串的长度存到列表length中。
2.求出字符串的最短长度minn。
3.初始化一个二维列表kuchiguse,其中有minn个一维列表。
4.将kuchiguse中每个一维列表转成集合去重。
5.如果其中的集合长度为1,则将集合中的字符放入out中。
6.判断out的长度,如果非空,则倒序输出out中字符,否则输出nai。

n = int(input())
l= []
leng = []
for i in range(n):
    s = input()
    length = len(s)
    l.append(s[::-1])
    leng.append(length)

minn = min(leng)
kuchiguse = [[] for i in range(minn)]
for i in l:
    for j in range(minn):
        kuchiguse[j].append(i[j])

kuchiguse = [set(i) for i in kuchiguse]
out = ''
for i in kuchiguse:
    if len(i) == 1:
        out += str(i.pop())
    else:
        break

if len(out):
    print(out[::-1])
else:
    print('nai')
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

D_ry

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值