[bzoj1684][Usaco2005 Oct]Close Encounter

1684: [Usaco2005 Oct]Close Encounter

Time Limit: 5 Sec Memory Limit: 64 MB
Submit: 533 Solved: 275
[Submit][Status][Discuss]
Description

Lacking even a fifth grade education, the cows are having trouble with a fraction problem from their textbook. Please help them. The problem is simple: Given a properly reduced fraction (i.e., the greatest common divisor of the numerator and denominator is 1, so the fraction cannot be further reduced) find the smallest properly reduced fraction with numerator and denominator in the range 1..32,767 that is closest (but not equal) to the given fraction. 找一个分数它最接近给出一个分数. 你要找的分数的值的范围在1..32767

Input

  • Line 1: Two positive space-separated integers N and D (1 <= N < D <= 32,767), respectively the numerator and denominator of the given fraction

Output

  • Line 1: Two space-separated integers, respectively the numerator and denominator of the smallest, closest fraction different from the input fraction.

Sample Input

2 3
Sample Output

21845 32767

OUTPUT DETAILS:

21845/32767 = .666676839503…. ~ 0.666666…. = 2/3.
HINT

Source

Silver

sol:
32767很小肯定枚举辣。这个i也可以二分辣,但是发现显然有一种方案很优秀,假设a/b无限接近i/j,则有a/b=i/j,那i就是a/b*j辣,那么优秀的方案一定是i,j和i+1,j。

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<iostream>
using namespace std;
int n,m;
inline int read()
{
    char c;
    int res,flag=0;
    while((c=getchar())>'9'||c<'0') if(c=='-')flag=1;
    res=c-'0';
    while((c=getchar())>='0'&&c<='9') res=(res<<3)+(res<<1)+c-'0';
    return flag?-res:res;
}
double a,b,a_,b_,ans,job;
inline void check(double x,double y)
{
    if(x*b==a*y) return;
    job=abs(x/y-a/b);
    if(job<ans)
    {
        ans=job;
        a_=x;
        b_=y;
    }
}
int main()
{
//  freopen("1684.in","r",stdin);
//  freopen(".out","w",stdout);
    scanf("%lf%lf",&a,&b);
    int i;
    ans=1e9;
    for(int j=1;j<=32767;++j)
    {
        i=(int)(a/b*j);
        check(i,j);
        check(i+1,j);
    }
    printf("%d %d",(int)a_,(int)b_);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值