hdu 2222 Keywords Search (ac自动机模板题)

Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 66480    Accepted Submission(s): 22301


Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.
 

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.
 

Output
Print how many keywords are contained in the description.
 

Sample Input
  
  
1 5 she he say shr her yasherhs
 

Sample Output
  
  
3
 

ac自动机详解: http://blog.csdn.net/creatorx/article/details/71100840


#include<stdio.h>
#include<string.h>
#include<malloc.h>

typedef struct node
{
	node *next[26];
	node *fail;
	int sum;
	//char c;

}node;

node *root;
char des[1000100];
node* que[1000100]; 
int ans;

void init(node *a)
{
	for(int i=0;i<26;i++)
		a->next[i]=NULL;
	a->fail=NULL;
	a->sum=0;
	//a->c='\0';
}
void Insert(char word[])
{
	node *p=root;
	for(int i=0;word[i];i++)
	{
		int x=word[i]-'a';
		if(!p->next[x])
		{
			p->next[x]=(node *)malloc(sizeof(node));
			init(p->next[x]);
			//p->c=x+'a';
		}
		p=p->next[x];
	}
	p->sum++;
}


void build_fail()
{
	int head,tail;
	head=tail=0;
	que[tail++]=root;

	while(head<tail)
	{
		node* tmp=que[head];
		head++;

		for(int i=0;i<26;i++)
		{
			if(!tmp->next[i]) continue;
			if(tmp==root) tmp->next[i]->fail=root;
			else
			{
				node *p=tmp->fail;
				while(p)
				{
					if(p->next[i])
					{
						tmp->next[i]->fail=p->next[i];
						break;
					}
					p=p->fail;
				}
				if(p==NULL) tmp->next[i]->fail=root;
			}
			que[tail++]=tmp->next[i];
		}
	}
}


void ac_automachine(char des[])
{
	node *p=root;
	for(int i=0;des[i]!='\0';i++)
	{
		int x=des[i]-'a';
		while(!p->next[x]&&p!=root) 
			p=p->fail;   
		                   //p是通过指向上一个已匹配单词对应单词表的节点,在同时在字母表中寻找当前待匹配的字母des[i]
		p=p->next[x];     //例如cdef,单词表中有cd,f,asdd,fe  , cd完成匹配后吗(此时p指向d),while是在以d结尾的节点的孩子节点中找e(即就是单词表中e前面是d的单词)
						   //找不到退出循环后(此时p=root)
		if(!p) p=root;   //又因为在root的孩子节点中也没有e那么结束,这条语句表明没有包含de的单词,也没有以e开头的单词
		node *tmp=p;
		while(tmp!=root)					//在单词表中找,与文本已匹配的字符串的以当前字符结尾的许多后缀中是否可以和单词表中其他单词匹配的
		{										//即该单词已完成匹配,那么与该单词的子串也一定是在文本中有匹配的,那么我们就只需要找出,单词表中是现在已匹配单词的后缀的单词就可以了
			if(tmp->sum>0)
			{
				ans+=tmp->sum;
				tmp->sum=0;  //因为每一个单词只能被匹配一次
			}
			//else break;
			tmp=tmp->fail;
		}
	}
}

int main()
{
	int t,n;
	char key[60];
	scanf("%d",&t);	
	while(t--)
	{
		ans=0;
		scanf("%d",&n);
		getchar();
		root=(node *)malloc(sizeof(node));
		init(root);
		for(int i=0;i<n;i++)
		{
			scanf("%s",key);
			Insert(key);
		}
		scanf("%s",des);
		build_fail();
		ac_automachine(des);
		printf("%d\n",ans);
	}
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值