hdu 6201 transaction transaction transaction (spfa求最长路)

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1518    Accepted Submission(s): 733


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell.
As we know, the price of this book was different in each city. It is ai yuan in i t city. Kelukin will take taxi, whose price is 1 yuan per km and this fare cannot be ignored.
There are
n1 roads connecting n cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer T ( 1T10 ) , the number of test cases.
For each test case:
first line contains an integer
n ( 2n100000 ) means the number of cities;
second line contains
n numbers, the i th number means the prices in i th city; (1Price10000)
then follows
n1 lines, each contains three numbers x , y and z which means there exists a road between x and y , the distance is z km (1z1000) .
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8

 


题意:

给你n个点书在当地的价格,以及两个点之间距离的花费,问你求选两个点使的利润最大


解析:

新建两个点,一个源点,一个汇点,再用spfa求最长路



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;

const int MAXN = 500010 ;
const int INF = 2000;

typedef struct node
{
	int u;
	int v;
	int value;
	int next;
}node;

node edge[MAXN];
int head[MAXN],cnt,n;
int d[MAXN],visit[MAXN];

void addedge(int u,int v,int value)
{
	edge[cnt].u=u;
	edge[cnt].v=v;
	edge[cnt].value=value;
	edge[cnt].next=head[u];
	head[u]=cnt++;
}

void spfa(int s,int e)
{
	queue<int> mq;
	mq.push(s);
	visit[s]=1;
	d[s]=0;
	while(!mq.empty())
	{
		int tmp=mq.front();
		mq.pop();
		
		for(int i=head[tmp];i!=-1;i=edge[i].next)
		{
			int v=edge[i].v;
			int value=edge[i].value;
			if(d[v]<d[tmp]+value)
			{
				d[v]=d[tmp]+value;
				if(!visit[v])
				{
					mq.push(v);
					visit[v]=1;
				}
			}
		}

		visit[tmp]=0;
	}
}

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(head,-1,sizeof(head));
		cnt=0;
		scanf("%d",&n);
		int a,b,c;
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&b);
			addedge(0,i,-b);
			addedge(i,n+1,b);
		}
		for(int i=1;i<=n-1;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			addedge(a,b,-c);
			addedge(b,a,-c);
		}
		memset(visit,0,sizeof(visit));
		for(int i=0;i<=n+1;i++)
			d[i]=-INF;
		spfa(0,n+1);
		printf("%d\n",d[n+1]);
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值