计蒜客 2017 ACM-ICPC 亚洲区(南宁赛区)网络赛 The Heaviest Non-decreasing Subsequence Problem

Let SSS be a sequence of integers s1s_{1}s1, s2s_{2}s2, ........., sns_{n}sn Each integer is is associated with a weight by the following rules:

(1) If is is negative, then its weight is 000.

(2) If is is greater than or equal to 100001000010000, then its weight is 555. Furthermore, the real integer value of sis_{i}si is si−10000s_{i}-10000si10000 . For example, if sis_{i}si is 101011010110101, then is is reset to 101101101 and its weight is 555.

(3) Otherwise, its weight is 111.

A non-decreasing subsequence of SSS is a subsequence si1s_{i1}si1, si2s_{i2}si2, ........., siks_{ik}sik, with i1<i2 ... <iki_{1}<i_{2}\ ...\ <i_{k}i1<i2 ... <ik, such that, for all 1≤j<k1 \leq j<k1j<k, we have sij<sij+1s_{ij}<s_{ij+1}sij<sij+1.

A heaviest non-decreasing subsequence of SSS is a non-decreasing subsequence with the maximum sum of weights.

Write a program that reads a sequence of integers, and outputs the weight of its

heaviest non-decreasing subsequence. For example, given the following sequence:

808080 757575 737373 939393 737373 737373 101011010110101 979797 −1-11 −1-11 114114114 −1-11 101131011310113 118118118

The heaviest non-decreasing subsequence of the sequence is <73,73,73,101,113,118><73, 73, 73, 101, 113, 118><73,73,73,101,113,118> with the total weight being 1+1+1+5+5+1=141+1+1+5+5+1 = 141+1+1+5+5+1=14. Therefore, your program should output 141414 in this example.

We guarantee that the length of the sequence does not exceed 2∗1052*10^{5}2105

Input Format

A list of integers separated by blanks:s1s_{1}s1, s2s_{2}s2,.........,sns_{n}sn

Output Format

A positive integer that is the weight of the heaviest non-decreasing subsequence.

样例输入
80 75 73 93 73 73 10101 97 -1 -1 114 -1 10113 118
样例输出
14


题意:
输入一串数,
1.数值<0 ,价值为0
2.数值>=10000,数值=数值-10000&价值为5
3.其余价值均为1

问你找出一个非递减子序列使价值最大

解析:
就是最长上升子序列模板题,g[k]表示当前价值下末尾最小的元素的值
#include<cstdio>
#include<cstring>
typedef	long long int ll;
const int MAXN = 2*1e5+10;

ll a[MAXN],g[MAXN*10],c[MAXN];
char str[MAXN*10];




ll binary_search(ll key,ll g[],ll left,ll right)
{
	ll mid;
	while(left<right)
	{
		mid=(left+right)>>1;
		if(key>=g[mid]) left=mid+1;
		else right=mid;
	}
	return left;
}

int main()
{
	/*while(gets(str)!=NULL)
	{
		ll temp=0;
		int cnt=0;
		int flag=0;
		for(int i=0;str[i]!='\0';i++)
		{
			if(str[i]>='0'&&str[i]<='9')
			{
				temp=temp*10+str[i]-'0';
			}
			else if(str[i]=='-')
			{
				flag=1;
			}
			else
			{
				if(flag) temp=-temp;
				a[cnt++]=temp;
				temp=0;
				flag=0;
			}
		}
		if(temp)
		{
            if(flag) temp=-temp;
			a[cnt++]=temp;
		}
	}*/
	int temp,cnt;
	cnt=0;
	while(scanf("%d",&temp)!=EOF)
	{
		a[cnt++]=temp;
	}
		for(int i=0;i<cnt;i++)
		{
			if(a[i]<0) c[i]=0;
			else if(a[i]>=10000)
			{
				a[i]=a[i]-10000;
				c[i]=5;
			}
			else
			{
				c[i]=1;
			}
		}
	
		ll ans=0;
		g[0]=0;
		ans=c[0];
		for(int i=1;i<=ans;i++)
			g[i]=a[0];
		for(int i=1;i<cnt;i++)
		{
            if(a[i]<0) continue;
			if(g[ans]<=a[i])
			{
				for(ll j=ans+1;j<=ans+c[i];j++)
					g[j]=a[i];
				ans+=c[i];
			}
			else
			{
				ll tmp=binary_search(a[i],g,1,ans+1);
				for(ll j=0;j<c[i];j++)
				{
					g[j+tmp]=a[i];
					if(j+tmp>ans) ans=j+tmp;
				}
			}
		}
		printf("%lld\n",ans);
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值