POJ - 1160 Post Office

Post Office
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 21002 Accepted: 11353

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between two positions is the absolute value of the difference of their integer coordinates. 

Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. 

You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

Source

题意:有n个村庄,要建立m个邮局,邮局只能建在村庄上,问各个村庄到各自最近邮局之和的最小值是多少?

题解:设dp[i][j]为建立i个邮局,覆盖前j个村庄的最小距离之和。

则转移方程dp[i][j] = min{dp[i - 1][k] + cost[k + 1][j]};

cost[k + 1][j]为在k + 1到j建立一个邮局,最短距离之和。

cost[k + 1][j] = cost[k + 1][j - 1] + a[j] - a[(k + 1 + j) / 2];

对于cost[i][k]可以O(n^2)求解。但对于dp[i][j]要n^3,故使用四边形优化成n^2即可。

对于k,维护一个s[i][j];记录其下凸曲线。

AC代码

#include <stdio.h>
#include <iostream>
#include <string>
#include <queue>
#include <map>
#include <vector>
#include <algorithm>
#include <string.h>
#include <cmath>
 
using namespace std;

const int maxn = 333, inf = 0x7fffffff;
int a[maxn], dis[maxn][maxn], dp[maxn][maxn], s[maxn][maxn];

void init(int m, int n){
	for(int i = 0; i <= m + 1; i++){
		for(int j = 0; j <= n + 1; j++){
			dp[i][j] = 0;
			dis[i][j] = 0;
		}
	}
}

void read(int n){
	for(int i = 1; i <= n; i++)
		scanf("%d", &a[i]);
	for(int i = 1; i <= n; i++)
		for(int j = i; j <= n; j++)
			dis[i][j] = dis[i][j - 1] + a[j] - a[(i + j) / 2];
	for(int i = 1; i <= n; i++)
		dp[1][i] = dis[1][i];
}

int main(){
	int n, m;
	while(scanf("%d %d", &n, &m) != EOF){
		init(m, n);
		read(n);
		for(int i = 2; i <= m; i++){
			s[i][n + 1] = n - 1; 
			for(int j = n; j >= i; j--){
				if(i == j)
					dp[i][j] = 0;
				else
					dp[i][j] = inf;
				for(int k = s[i - 1][j]; k <= s[i][j + 1]; k++){
					if(dp[i][j] > dp[i - 1][k] + dis[k + 1][j]){
						dp[i][j] = dp[i - 1][k] + dis[k + 1][j];
						s[i][j] = k;
					}
				}
			}
		}
		printf("%d\n", dp[m][n]);
	}
	return 0;
} 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值