2018暑假第一次多校K题

Time Zone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2023    Accepted Submission(s): 628


 

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s.

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106), indicating the number of test cases. For each test case:
The first line contains two integers a, b (0≤a≤23,0≤b≤59) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9).

 

 

Output

For each test, output the time in the format of hh:mm (24-hour clock).

 

 

Sample Input

 

3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

 

 

Sample Output

 

11:11 12:12 03:23

题意:当前时区是UTC+8,给定某个时间和对应时区,问UTC+8的对应时间

因为UTC后面可能是浮点数,浮点数精度会出问题,所以读浮点数时转换成读字符串,然后转换成分钟,再把当前时间转换成分钟,然后加上读取的分钟,减去8*60,再得到小时即可

代码

#include <iostream>
#include <stdio.h>
#include <vector>
#include <string.h>
#define ll long long

using namespace std;

int main(){
    int t, n, a, b, day, mine, c;
    day = 24 * 60;
    char temp[4];
    char tt[11];
    while(scanf("%d", &t) != EOF){
        while(t--){
            scanf("%d %d %c%c%c%c%s", &a, &b, &temp[0],&temp[1],&temp[2],&temp[3], tt);
            c = 0;
            for(int i = 0; i < strlen(tt);i++){
                if(tt[i]!='.'){
                    c = (tt[i] - '0') + c * 10;
                }
                else{
                    c = (c * 10 + tt[i+1]-'0') * 6;
                    break;
                }
                if(i == strlen(tt) - 1)
                    c *= 60;
            }
            if(temp[3] == '-')
                c=-c;
            mine = (a * 60 + b - 8 * 60 + c + 10 * day) % day;
            printf("%02d:%02d\n",mine/60,mine%60);
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值