POJ 3096 Surprising Strings

     Surprising Strings

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.


Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input
The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output
For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input
ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*
Sample Output
ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.

BCBABCC is NOT surprising.


隔相同距离的两个字符组成一组,看有没有重复。两个字符有26*26种组合,将字符组合转化为数字进行判断,

枚举间隔i,判断该间隔下有无重复的的组合。注意边界,和清除标记。

#include<iostream>
#include<string>
#include<string.h>

using namespace std;
int c[85];
bool v[700];
int n;
string s;
int main()
{
    while (cin>>s&&s[0]!='*')
    {
        n=s.size();
        for(int i=0;i<n;i++)
            c[i]=s[i]-'A';
        int sign=1;
        for(int i=1;i<n-1&&sign;i++)
        {
            memset(v,false,sizeof(v));
            for(int j=0;j<n-i;j++)
            {
                int temp=c[j]*26+c[j+i];
                if(!v[temp])v[temp]=true;
                else {sign=0;break;}
            }
        }
        if(sign)cout<<s<<" is surprising."<<endl;
        else cout<<s<<" is NOT surprising."<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值