HDU3172-Virtual Friends

Virtual Friends


These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends’ friends, their friends’ friends’ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.
Your task is to observe the interactions on such a website and keep track of the size of each person’s network.
Assume that every friendship is mutual. If Fred is Barney’s friend, then Barney is also Fred’s friend.

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

Sample Input
1
3
Fred Barney
Barney Betty
Betty Wilma

Sample Output
2
3
4


题意:

给出m对朋友关系,且朋友关系可以传递,输出朋友总数。

思路:

最基本的并查集,不知道可以先去学学,链接。很生动。
这题有个坑,就是多组多组输入,注意两个多组。
所以输入要用

while(cin>>T)
    {
        while(T--)
        {

这样的读入。(不是很懂出题人意欲何为)
卡了我好几个小时,心态爆炸。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<map>
#include<string.h>
#include<sstream>
#define mem(a,b)  memset((a),(b),sizeof(a));
using namespace std;
const int sz=1e5+5;
int bc[sz];
map<string,int>m;

int main()
{

    ios::sync_with_stdio(false);
    //freopen("text.txt", "r", stdin);
    int T;
    while(cin>>T)
    {
        while(T--)
        {
        m.clear();
        int n;
        cin>>n;
        int k=1;
        mem(bc,-1);
        while(n--)
        {
            char s1[25],s2[25];
            cin>>s1>>s2;
            if(m.find(s1)==m.end())
                m[s1]=k++;
            if(m.find(s2)==m.end())
                m[s2]=k++;
            //map<string,int>::iterator it;
            //for(it=m.begin();it!=m.end();it++)
            //  cout<<it->first<<it->second<<endl;
            int t1=m[s1],t2=m[s2];
            //cout<<t1<<" "<<t2<<endl;
            while(bc[t1]>0)
                t1=bc[t1];

            while(bc[t2]>0)
                t2=bc[t2];

            if(t1!=t2)
            {
                bc[t1]+=bc[t2];
                bc[t2]=t1;
            }
            printf("%d\n",-bc[t1]);
        }
    }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值