【PAT甲级A1004 】Counting Leaves (30分)(c++)

1004 Counting Leaves (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

题意:

给出总结点数n,以及根结点数m,m行根节点数包括(结点id ,结点下子节点个数k ,子结点idk ),要求输出每一层的叶子结点个数。

思路:

题目给了一棵树,也给了每个结点的id,由于不确定子结点的个数,我们可以用vector容器去存储,如例程的01结点的子结点02表示成node[1][0]=2;如01结点的子结点有02 04 05 07可以表示成

node[1][0]=2;
node[1][1]=4;
node[1][2]=5;
node[1][3]=7;

然后利用深度优先来遍历这棵树,边界为node[root].empty(),当所遍历的结点没有子结点时,记录所在层数,该层叶子结点数+1。

参考代码:

#include <iostream>
#include <vector>
using namespace std;
const int maxn=101;
vector<vector<int> > node(maxn,vector<int>());
int n,m,maxdepth(0),numdepth[maxn]={0};
void dfs(int root,int depth){
    if(node[root].empty()){
        numdepth[depth]++;
        maxdepth=max(maxdepth,depth);
        return;
    }
    for(int i=0;i<node[root].size();i++)
        dfs(node[root][i],depth+1);
}
int main() {
    cin>>n>>m;
    for(int i=0;i<m;i++){
        int id,k,idk;
        cin>>id>>k;
        for(int j=0;j<k;j++){
            cin>>idk;
            node[id].push_back(idk);
        }
    }
    dfs(1,0);
    for(int i=0;i<=maxdepth;i++){
        if(i<maxdepth) cout<<numdepth[i]<<" ";
        else cout<<numdepth[i]<<endl;
    }
    return 0;
}

如有错误,欢迎指正

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值