【PAT甲级A1051】Pop Sequence (25分)(c++)

1051 Pop Sequence (25分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, …, N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:
For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题意:

将1到N个数压入栈,栈内最多存储m个数,根据不同的出栈顺序可以得出不同的数组,判断所给数组是否可以由出栈所组成。

思路:

由于输入时顺序输入,所以当读入数字时判断

  • 若栈为空,或者读入数字比栈首数字大,则需要继续将顺序数字入栈(入栈过程中,栈的大小超出限制,则这组数就不OK),压到读入数字时,将栈首pop,这样就得到了这个数字;
  • 若读入数字不等于栈首数字,那么这组数也不ok;
  • 若读入数字等于栈首数字,那么pop栈首,得到这个数字,继续读取下一个数。

参开代码:

#include <iostream>
#include <stack>

using namespace std;

int main() {
    int m, n, k;
    scanf("%d%d%d", &m, &n, &k);
    int arr[n + 1], temp;
    for (int i = 0; i <= n + 1; i++)arr[i] = i;
    for (int i = 0; i < k; i++) {
        stack<int> st;
        int index = 1, flag = 1;
        for (int j = 0; j < n; j++) {
            scanf("%d", &temp);
            if (st.empty() || temp > st.top()) {
                while (arr[index] <= temp)
                    st.push(arr[index++]);
                if (st.size() > m) {
                    flag = 0;
                } else st.pop();
            } else if (st.top() != temp) {
                flag = 0;
            } else st.pop();
        }
        printf("%s\n", flag == 1 ? "YES" : "NO");
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值