【PAT甲级A1066】Root of AVL Tree (25分)(c++)

1066 Root of AVL Tree (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

题意:

将所给数组构建平衡二叉树。

思路:

默写平衡二叉树构建模板。(参考《算法笔记》)

参考代码:

#include <cstdio>
#include <iostream>
using namespace std;
struct node{
    int data,height;
    node *left,*right;
};
node* newnode(int v){
    node* Node=new node;
    Node->data=v;
    Node->height=1;
    Node->left=Node->right=NULL;
    return Node;
}
int getheight(node* root){
    if(root==NULL)return 0;
    return root->height;
}
void updateheight(node* root){
    root->height=max(getheight(root->left),getheight(root->right))+1;
}
int BF(node* root){
    return getheight(root->left)-getheight(root->right);
}
void L(node* &root){
    node* temp=root->right;
    root->right=temp->left;
    temp->left=root;
    updateheight(root);
    updateheight(temp);
    root=temp;
}
void R(node* &root){
    node* temp=root->left;
    root->left=temp->right;
    temp->right=root;
    updateheight(root);
    updateheight(temp);
    root=temp;
}
void insert(node* &root,int v){
    if(root==NULL){
        root=newnode(v);
        return;
    }
    if(v<root->data){
        insert(root->left,v);
        updateheight(root);
        if(BF(root)==2){
            if(BF(root->left)==1)R(root);
            else if(BF(root->left)==-1){
                L(root->left);
                R(root);
            }
        }
    }else{
        insert(root->right,v);
        updateheight(root);
        if(BF(root)==-2){
            if(BF(root->right)==-1)L(root);
            else if(BF(root->right)==1){
                R(root->right);
                L(root);
            }
        }
    }
}
int main() {
    int n,data;
    scanf("%d",&n);
    node* root=NULL;
    for(int i=0;i<n;i++){
        scanf("%d",&data);
        insert(root,data);
    }
    printf("%d\n",root->data);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值