1066 Root of AVL Tree(25 分)(C++)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

 

 

 

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

 

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then Ndistinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

考点:AVL树

插入时四种旋转:左单循环、右单循环、左右双循环、右左双循环

以左单循环和右左双循环为例。

左单循环:插入时插在右子树。

右左双循环插入在右子树的左子树,先对右子树进行右循环,再对总树进行左循环。

#include <iostream>
using namespace std;
struct node{
	int val;
	node *left, *right;
	node(int x): val(x), left(nullptr), right(nullptr){};
};
int getHeight(node *root){
	if(root == nullptr)
		return 0;
	return max(getHeight(root->right), getHeight(root->left)) + 1;
}
node *rotateL(node *root){
	node *temp = root->right;
	root->right = temp->left;
	temp->left = root;
	return temp;
}
node *rotateR(node *root){
	node *temp = root->left;
	root->left = temp->right;
	temp->right = root;
	return temp;
}
node *rotateLR(node *root){
	root->left = rotateL(root->left);
	return rotateR(root);
}
node *rotateRL(node *root){
	root->right = rotateR(root->right);
	return rotateL(root);
}
node *insert(node *root, int value){
	if(root == nullptr)
		root = new node(value);
	else if(root->val > value){
		root->left = insert(root->left, value);
		if(getHeight(root->left) - getHeight(root->right) == 2)
			root = value < root->left->val ? rotateR(root) : rotateLR(root);
	}		
	else{
		root->right = insert(root->right, value);
		if(getHeight(root->left) - getHeight(root->right) == -2)
			root = value > root->right->val ? rotateL(root) : rotateRL(root);
	}
	return root;
}
int n, temp;
int main(){
	scanf("%d", &n);
	node *root = nullptr;
	for(int i = 0; i < n; ++ i){
		scanf("%d", &temp);
		root = insert(root, temp);
	}
	printf("%d", root->val);
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值