【PAT甲级A1081】Rational Sum (20分)(c++)

1081 Rational Sum (20分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:250 ms
内存限制:64 MB

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

题意:

将所给分数相加,并以带分数的形式输出。

思路:

考验分数的表达方式,有理化,以及输出。
1.分数有理化,有理化中需要计算分母的最大公约数,这里有两种方法,一中是<algorithm>中的__gcd()函数,另一种就直接自己写一个最大公约数函数:

int gcd(int a, int b) {
    if (b == 0)return a;
    else return gcd(b, a % b);
}

2.分母不为负数。

参考代码:

#include <cstdio>
#include <algorithm>

using namespace std;
struct fraction {
    int up, down;
} f[101], f0 = {0, 1};

void reduction(fraction &x) {
    if (x.down < 0) {
        x.down = -x.down;
        x.up = -x.up;
    }
    if (x.up == 0)x.down = 1;
    else {
        int gcd = __gcd(x.up, x.down);
        x.up /= gcd;
        x.down /= gcd;
    }
}

fraction add(fraction a, fraction b) {
    fraction result;
    result.up = a.up * b.down + b.up * a.down;
    result.down = a.down * b.down;
    reduction(result);
    return result;
}

void showfraction(fraction x) {
    if (x.down == 1) {
        printf("%d\n", x.up);
    } else if (abs(x.up) > x.down) {
        printf("%d %d/%d\n", x.up / x.down, x.up % x.down, x.down);
    } else printf("%d/%d\n", x.up, x.down);
}

int main() {
    int n;
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%d/%d", &f[i].up, &f[i].down);
        f0 = add(f0, f[i]);
    }
    showfraction(f0);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值