【PAT甲级A1093】Count PAT‘s (25分)(c++)

1093 Count PAT’s (25分)

作者:CAO, Peng
单位:Google
代码长度限制:16 KB
时间限制:150 ms
内存限制:64 MB

The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

题意:

计算所给字符串中,按顺序能组合成几组“PAT”。

思路:

由于PAT的字符顺序是固定的,所以可以找“A”,每个"A"能组成多少个“PAT”由“A”左边有多少个“P”和右边有多少个“T”组成,如果各有两个,那么和这个“A”组成的“PAT”就有2*2个,因此这题就变成了统计每个“A”左边有右边有多少个“P”和“T”。

参考代码:

 #include <iostream>
#include <string>
#include <vector>

using namespace std;

int main() {
    string str;
    cin >> str;
    int len = str.length(), cnt = 0;
    vector<int> p(len, 0), t(len, 0);
    for (int i = 0; i < len; i++) {
        if (i != 0)p[i] = p[i - 1];
        if (str[i] == 'P')p[i]++;
    }
    for (int i = len - 1; i >= 0; i--) {
        if (i != len - 1)t[i] = t[i + 1];
        if (str[i] == 'T')t[i]++;
        else if (str[i] == 'A') {
            cnt = (cnt + p[i] * t[i]) % 1000000007;
        }
    }
    printf("%d", cnt);
}

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值