【PAT甲级A1098】Insertion or Heap Sort (25分)(c++)

1098 Insertion or Heap Sort (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in the first line either “Insertion Sort” or “Heap Sort” to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题意:

判断所给数列时按照插入排序还是堆排序。

思路:

插入排序,将后无序段的第一个元素插入有序段中的相应位置。判断的时候只要判断无序段是否与原数列相等。

  • 堆排序,将数列进行大顶堆操作,此时数列列首定是最大值,然后与列尾元素交换,此时列尾为有序段,再对无序段大顶堆,再交换。。以此类推。判断时,从后往前,当数值小于列首元素时,说明列首与无序段列尾元素还没交换,若要执行下一迭代,只要交换列首与无序段列尾元素,再对新的无序段大顶堆操作。
  • 大顶堆操作,与比自身大的孩子结点交换。

参考代码:

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

void downadjust(vector<int> &heap, int low, int high) {
    int i = low, j = i * 2;
    while (j <= high) {
        if (j + 1 <= high && heap[j + 1] > heap[j])j = j + 1;
        if (heap[j] > heap[i]) {
            swap(heap[j], heap[i]);
            i = j;
            j = i * 2;
        } else break;
    }
}

int main() {
    int n, i, j;
    scanf("%d", &n);
    vector<int> ori(n + 1), final(n + 1);
    for (i = 1; i <= n; i++)scanf("%d", &ori[i]);
    for (i = 1; i <= n; i++)scanf("%d", &final[i]);
    for (i = 1; i <= n - 1 && final[i] <= final[i + 1]; i++);
    for (j = i + 1; j <= n && ori[j] == final[j]; j++);
    if (j == n + 1) {
        printf("Insertion Sort\n");
        sort(final.begin() + 1, final.begin() + i + 2);
    } else {
        printf("Heap Sort\n");
        for (j = n; j > 2 && final[j] >= final[1]; j--);
        swap(final[j], final[1]);
        downadjust(final, 1, j - 1);
    }
    for (i = 1; i <= n; i++) {
        if (i != 1)printf(" ");
        printf("%d", final[i]);
    }
    return 0;
}

如有错误,欢迎指正

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值