【PAT甲级A1105】 Spiral Matrix (25分)(c++)

1105 Spiral Matrix (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:200 ms
内存限制:64 MB

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4. The numbers in a line are separated by spaces.

Output Specification:
For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

题意:

将所给数列按从大到小的顺序顺时针排列在mn的矩阵中,其中mn为数列大小,行数和列数相差要求相差最小,且行数大于等于列数。

思路:

先找列数,列数从小于sqrt(n)的整数中找最大等被n整除的数。
然后按照右下左上的顺序循环填充矩阵,直到填充满为止,循环的过程中也要时刻保证不能填充数列外的内容(即index<n)。

参考代码:

#include <iostream>
#include <cmath>
#include <vector>
#include <algorithm>

using namespace std;

int main() {
    int n, col, row;;
    scanf("%d", &n);
    for (col = sqrt(n); col >= 1; col--) {
        if (n % col == 0) {
            row = n / col;
            break;
        }
    }
    int G[row][col], index = 0, level = 0;
    vector<int> v(n);
    for (int i = 0; i < n; i++)scanf("%d", &v[i]);
    sort(v.begin(), v.end(), greater<int>());
    while (index < n) {
        for (int i = level; i < col - level && index < n; i++)
            G[level][i] = v[index++];
        for (int i = level + 1; i < row - level && index < n; i++)
            G[i][col - level - 1] = v[index++];
        for (int i = col - 2 - level; i >= level && index < n; i--)
            G[row - 1 - level][i] = v[index++];
        for (int i = row - 2 - level; i >= level + 1 && index < n; i--)
            G[i][level] = v[index++];
        level++;
    }
    for (int i = 0; i < row; i++) {
        for (int j = 0; j < col; j++) {
            if (j != 0)printf(" ");
            printf("%d", G[i][j]);
        }
        printf("\n");
    }

    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值