【PAT甲级A1115】 Counting Nodes in a BST (30分)(c++)

1115 Counting Nodes in a BST (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  • The right subtree of a node contains only nodes with keys greater than the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:
For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

题意:

将所给数列构建二叉查找树(左节点小于等于父节点,右结点大于父节点),然后输出最后两层结点个数的和。

思路:

构建二叉查找树,当结点为空时构建结点,当结点满足二叉查找树性质时,继续往下找插入点,在对的位置(空节点)插入这个值。然后容深度优先遍历结点同时记录每一层的节点个数,并记录最深层数。

参考代码:

#include <iostream>
#include <algorithm>

using namespace std;
int maxdepth = 0, sum[1000] = {0};

struct Node {
    int data;
    Node *left, *right;
    Node(int v) : data(v), left(NULL), right(NULL) {}
};

void insert(Node *&root, int v) {
    if (root == NULL) {
        root = new Node(v);
        return;
    }
    if (v <= root->data)insert(root->left, v);
    if (v > root->data)insert(root->right, v);
}

void dfs(Node *root, int depth) {
    if (root == NULL) {
        maxdepth = max(maxdepth, depth);
        return;
    }
    sum[depth]++;
    dfs(root->left, depth + 1);
    dfs(root->right, depth + 1);
}

int main() {
    int n, v;
    Node *root = NULL;
    scanf("%d", &n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &v);
        insert(root, v);
    }
    dfs(root, 0);
    printf("%d + %d = %d", sum[maxdepth - 1], sum[maxdepth - 2], sum[maxdepth - 1] + sum[maxdepth - 2]);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值